View Full Version : Need some ppp help

03-30-2002, 01:38 AM
I've searched the forums here and elsewhere, but cannot find another question like this. I hope someone can help me.

I've enabled PPP on my TiVO to a local Linux box, but it seems to drop every other packet. This is preventing file transfers, but doesn't seem to stop me from telnetting in. Without file transfers, I can't do any useful hacking ... :p

To give you an idea:
> ping tivo
PING tivo ( 56 data bytes
64 bytes from icmp_seq=0 ttl=255 time=29.783 ms
64 bytes from icmp_seq=2 ttl=255 time=19.789 ms
64 bytes from icmp_seq=4 ttl=255 time=19.790 ms
64 bytes from icmp_seq=6 ttl=255 time=19.788 ms
64 bytes from icmp_seq=8 ttl=255 time=19.789 ms

--- tivo ping statistics ---
9 packets transmitted, 5 packets received, 44% packet loss

> telnet tivo
Connected to tivo.
Escape character is '^]'.

bash-2.02# pwd

My TiVO is at 2.5.1, but I'm using my old 1.3 pppd. I used the original TiVO cable with a null modem adapter, then tried another one, same problem. I have used speeds of 115200, 57600 and 9600, with the same results. I've tried two different computers as the host-side, each with a different linux distribution, same issue.

Any suggestions?

[edited to fix a typo]

03-31-2002, 01:53 AM
I don't use PPP, but here's a site (http://www.caseserve.com/ht/TiVo/PPP/PPPonTiVo.htm) that might help.

03-31-2002, 04:27 AM
Thanks for the site link, BubbleLamp.

I'm tempted to try using a windows box next, but I'm still hopeful that someone has run across this before and knows what I've done wrong... ;)


04-01-2002, 06:33 PM
Are you getting any errors in /var/log/messages on the linux box? What is the output of 'ifconfig -a ppp0' and 'ifconfig -a ppp1' on the linux box and tivo, respectively? I run a similar setup and had problems at 115200, but run quite well at 57600.

05-09-2003, 07:34 PM
I am having the exact same problem. It seems every other packet is getting dropped. Telnet works, but slow but file transfers won't work at all.

I've tried different cables, different ports, different speeds...all the same.

I used to have this setup before and everything worked fine. Any ideas? I need to upgrade to 2.5.2, and I don't feel like pulling everything out just to get the hard drive out.