PDA

View Full Version : PPP problems, help



Mjolinor
04-09-2002, 12:54 PM
Trying to get PPP to work with my Tivo, read everything I could find and then I followed the instructions at

http://www.caseserve.com/ht/TiVo/PPP/PPPto9X.htm

excluding the bash prompt part because I already have this.

I couldn't get joe to behave with hyper terminal so edited in windows (see end of post)

The results was a startling nothing. Dial up server sat for ever saying monitoring.

Checked everything and then redid it all from scratch and exactly the same.

Restored averything to how it was before I started and followed the instructions at

http://www.pineaus.com/HOWTO/Tivo-DSL-HOWTO.html

Not knowing what I am doing is a problem here because this site only gives me instructions for interfacing with a Linux machine.

So with the Windows bit from the first URL and the Tivo bit from the second URL I now have dial up server saying answering then hanging up then monitoring, the Tivo reboots and it carries on for ever, answering, hanging up, reboot Tivo.

Not I think as it should be.

I tried one or two other sites with pretty much the same results so I decided to stop following instructions and try to decide how to do it.

I did the following.

In rc.sysinit where the decision to check shondss= true and run bash, I put the following:
************************************
#/*/* I am going to put my PPP login immediately after the shondss is proved not true

if [ "$shondss" = true ]; then
echo "Starting bash on /dev/ttyS3"
bash </dev/ttyS3 >& /dev/ttyS3 &
else
echo "Starting pppd on /dev/ttyS3" > /dev/ttyS3
/etc/startpppd.ttyS3 &
tnlited 23 /bin/bash -login &

fi
**********************************

I created a file called startpppd.ttyS3 in the /etc directory.

The contents are:
*********************************
#/etc/startpppd
while : ; do echo "CLIENTCLIENT" > /dev/ttyS3
/sbin/custpppd nodetach file /etc/ppp-options.ttyS3
sleep 30;
done
*********************************

I created a file called ppp-options.ttyS3
The contents are:
*************************
#/etc/ppp-options.ttyS3
/dev/ttyS3
9600
nocrtscts
noauth
local
#xonxoff
asyncmap 0
netmask 255.255.255.0
defaultroute
lcp-echo-failure 2
lcp-echo-interval 60
refuse-chap
connect "/etc/chat.ttyS3"
*****************************

chat.ttyS3 has nothing in it.

I figured that would all work though I don't really know what I am doing. I set win 98 to no password and I also tried making pap-secrets with tivo * tivo in and setting the password in dial up server.

What i get now is, monitoring, answering, hanging up at 30 second intervals.

All editing was done using ultraedit in win 98, I made sure there are no 0d hex values in any of the files I sent ( as far as I can find out this is the only difference )

I think what I am looking for is the dial up server saying connected,
this is before I go to the next stage and learn what the hell telnet is and NAT and what NAT has to do with it all

Here is an example of my modem log file

http://www.dknpowerline.com/pictures/modem.txt

and here is an example of my PPP log file.

http://www.dknpowerline.com/pictures/ppplog.txt

Well and truly fallen at the first fence, I am sane, what am I doing today, NAT PPP CHMOD cp zmodem edit chmod transfer rm chmod cp etc etc etc.