View Full Version : help getting linux to see TiVo disk

04-18-2002, 04:51 PM
In the last week I did my first linux install and build my first kernel(s) so please excuse me if this is an easy one. I patched the kernel and enabled tivo (and mac) partitions. I can see that it is enabled in the kernel configurator. But still no luck. The page I got the patch from said I would want:


passed to the kernel, so my lilo.conf now has the line:

append "hdc=swapdata"

but still no good. I saw something about bswap (looked at isolinux.xfg on the boot cd) so I tried that too but still no good. Now I see things about dma but I don't know if I have it on now and I don't know how to turn it off, and I also don't know if that's where my problem is. Can anyone give me a hand?

04-18-2002, 06:15 PM
cat /proc/ide/hdc/settings now verifies that I have byte swapping on and dma off. Still I get:

/dev/hdc4: Success
mount: you must specify the filesystem type

I can mount this drive with no problems from the boot cd or floppy. Could it be a kernel problem? the kernel configurator verifies that the TiVo partition support is in there. Arg! Running very low on ideas, all the reading I've done tells me that at this point I should not have a problem mounting the drive.

04-18-2002, 06:56 PM
During boot, does the TiVo disk get recognized, and the partitions listed in the messages (see them after boot with "dmesg")?

04-18-2002, 07:17 PM
hdc: unknown partition table

I left out one detail - I put a tivo image on this drive but have not yet booted it in a tivo. Is there some magic that happens the first time you boot a drive with an image? didn't see it mentioned anywhere.

So the boot process can't recognize the partition table but does turn on byteswapping and off dma (well I turn it off as soon as it is done booting with hdparm -d0 /dev/hdc). I would suspect a bad image except that I can mount it with no problems as /dev/hdc4 using the boot cd. (HEY! That's your boot cd! Ever get the feeling you have been talking to someone famous and didn't even know it? :))

04-19-2002, 04:17 PM
Originally posted by jasper
hdc: unknown partition table

So the boot process can't recognize the partition table but does turn on byteswapping and off dma (well I turn it off as soon as it is done booting with hdparm -d0 /dev/hdc).

There's your problem. As long as DMA is still on, the "bswap" doesn't do anything - so that while you boot, there's no byteswapping, hence "hdc: unknown partition table". Turning dma off after boot should enable the byteswapping, though. I know it did for me when I was testing the boot CD. What happens if, after you turn DMA off and byteswapping on, you try to take a look at the partition table of hdc with fdisk or cfdisk? Does it see it, or not?

04-20-2002, 03:34 PM
I can turn of dma for that drive after boot with hdparm but still can't mount at that point. I can try with fdisk or something (you mean like dos fdisk?). Back up one step though, what param can I pass in lilo.conf that will make dma be turned off for that drive at boot? I tried turning it off in the BIOS but it had no effect. I saw some reference to "nodma" but I couldn't get it to work and I would like to leave it on for my main drive anyway. What should I try from here? Linux is so cool and yet SO frustrating.

04-23-2002, 01:00 PM
It's been days now and I haven't gotten any further. Boot CD works great, RedHat 7.2 still can't see it. What is the best way to turn off dma? Bios? Some arg to that kernel in lilo? I guess I could try to find a pre-compiled kernel with TiVo support built in to make sure I built my kernel correctly. I will work on that. In the mean time, any additional help would be greatly appreciated (come over and give me a hand and I'll buy you lunch....). :)