View Full Version : help w/ bash

06-06-2002, 01:38 AM
I got 25 xtreme loaded fine. now I'm trying to get the sub hack.
I fired up tera term, hit return and got bash 2.02#.
Now I type cd/ , and I get "no such file on cd "
Tried it on hyperterm and teraterm. both saying the same.
What' s missing?

06-06-2002, 02:51 AM
You need to put a space between the CD and the /.

06-07-2002, 02:04 AM
I tried that cd / and it just went to bash 2.02# again on the next line. What's suppose to come up? something like a directory?
Sorry I'm a real newbie.

I tried the long way to get the life sub and hooked up the HD to my PC. and it worked, I got lifetime.
here's what I did..
mkdir /mnt/td
mount /dev/hdc4 /mnt/td
touch /mnt/td/etc/SubTest
chmod +x /mnt/td/etc/SubTest
umount hdc4
When I typed umount hdc4, It said hdc not valid or something like that. I hooked it up to dtivo, did the call and it worked. sys info says... 5 lifetime. since I really don't know what I'm doing, would something go wrong later on?
also how important is it to clear log?
I would still want to get that bash going.

06-07-2002, 06:50 AM
Originally posted by krugans
Now I type cd/ , and I get "no such file on cd "

Shouldn't it be cd \ not cd / ?

06-07-2002, 10:03 AM
krugans, you should take care of the logs, or one day you'll find your /hack directory is gone.

donbadabon, cd \ is in the DOS world, cd / is unix. Neither do anything other than take you to the root directory.

Suggest you learn the basic unix commands, you'll need them. It's not really that hard once you know a handful.

06-07-2002, 11:56 AM
Originally posted by krugans
I tried that cd / and it just went to bash 2.02# again on the next line. What's suppose to come up? something like a directory?

If you want to have BASH show your current directory, just add the following line to your .bashrc file (located in the root directory), and your prompt will always display your current directory. You can also enter it in on the command line to see what it will look like. Then you won't have to reboot.:

PS1="bash-2.02 [\w] \$ "

06-08-2002, 02:31 AM
Try again,

fired up tera term and i get:

bash 2.02#(right here I type cd / then I get)
bash 2.02#

Is that whats suppose to happen? I don't know if Im communicating w/ anything. My PC should be talking to the Dtivo HD, right?

06-10-2002, 04:58 AM
bash will not return any communications to you unless you ask for it. when you do a cd / it is changing directories (thats all you asked it to do)

To see whats in there you'll need to send the rest of the linux commands to the tivo, modify the path to see them or type lots, and reboot it. Then you'll see something like

bash 2.02#cd / <enter>
bash 2.02#ls <enter>

then you'll see a directory listing. If you're not comfortable modifying the path you could upload these commands to /var/hack/bin (or something like that) and type the path like

bash 2.02#/var/hack/ls

Hope that makes it a bit clearer to you. If 'ya get a bash prompt you're talking to the tivo.

Hope this helps.

06-18-2002, 02:48 AM
I got it somewhat. but its going to be a while to really understand all this. Using Joe was a pain, it keeps corrupting the the lines I'm putting in. I had to re-xtreme but I got it working, got lifetime and I got clearlogs working.
happy for now till the next hack....

plus anything else I need to do?
is there a way to practice this on a mock HD w/out actually messing w/ my tivo unit?

06-18-2002, 10:49 AM
Make sure your terminal is set to 25 lines, or JOE is hard to work with. Also, if you ever think you've messed up in the editing, press CTRL-C. This will exit without making any changes.