PDA

View Full Version : Help! My videos look like crap!



JeffDogg1979
12-16-2002, 09:32 PM
First off...I love this forum. Lots of good information and tools :)

Now for the bad....

I'm using tytool5 to extract my content and I'm using vsplit mode. When I look at the m2v file I get tons of horizontal lines whenever the picture moves. The "quality" setting makes no difference and I am really disappointed because I get this on every piece of content on the Tivo.

I have a Phillips SA with a 120gig drive if that's any help...I don't understand why it looks fine on the TV when I use the Tivo to play them, but it looks terrible when I pull the TY file off it.

I really need help here...I don't want to lose my "Babylon 5: Crusade" and "Alias" seasons. I've attached a couple pics as examples.

TIA
Jeff

FreydNot
12-17-2002, 01:45 AM
Those lines are an artifact from "Interlacing". This is a method NTSC (and PAL) uses to keep the 30 frame per second video from flickering.

You have two options. The easiest one is to use a player (or more specificly an mpeg2 decoder which will preform a deinterlace on the fly (often called "bob" or "weave"). The other option is to completely re-encode the video using a program that will de-interlace during encoding. Look up VirtualDub or AviSynth.

Fugg
12-17-2002, 11:26 AM
since i started using windvd and it's installed codecs i have noitced very little interlacing.

i don't know if it's my setup or what, but it works like a champ.

automaticlly does a nice 4:3 strech, too. it even allows windows media player to work with it's codecs.

Nikki
12-18-2002, 11:20 AM
Fugg,

By default WinDVD will de-interlace. The settings are in the Properties->Display->Custom quality options.

If your graphics card had a TV out option and you wanted to watch the mpeg through your TV via your PC, then you would need to remove de-interlacing otherwise the video would look jerky.

Regards,

Nikki

CroW
10-25-2004, 09:05 AM
Bumping this topic to see if anyone has a workaround for this problem...
I extract the TY file from TiVo using TyTool 9R17?... I then mux the TY to VOB, create my IFOs and burn.
When trying to view my burned DVDs on my home theater Pioneer DVD players and the quality is OK as long the image is moving much. When there is much action, the interlace artifacts make the video look like crap.
I'm assuming that once I get the TY stream muxed to VOB that I'll need to do some sort of de-interlace transcoding before creating my IFOs..

How can I fix this to make it worth viewing?

Thanks,

--CroW

malfunct
10-25-2004, 10:54 AM
Bumping this topic to see if anyone has a workaround for this problem...
I extract the TY file from TiVo using TyTool 9R17?... I then mux the TY to VOB, create my IFOs and burn.
When trying to view my burned DVDs on my home theater Pioneer DVD players and the quality is OK as long the image is moving much. When there is much action, the interlace artifacts make the video look like crap.
I'm assuming that once I get the TY stream muxed to VOB that I'll need to do some sort of de-interlace transcoding before creating my IFOs..

How can I fix this to make it worth viewing?

Thanks,

--CroW

How does this look on the PC when you play it? Also do you have the DVD player de-interlace it before sending to the tv or do you play it interlaced and let the tv de-interlace it? I've heard that one way is better than the other but can't for the life of me remember. You could probably re-encode the video to progressive before putting it on the dvd but that runs through a whole number of little issues and depending on the software you use to de-interlace may have far more artifacts than you are getting now. Anyways I'd mess with different settings on your display and dvd player to see if you can improve the de-interlacing that happens there.

CroW
10-25-2004, 11:16 AM
Haven't tried it on the PC yet.. Can't verify right now as I am at work. Both DVDs are outputting in progressive scan so perhaps thats a potential cause. Thanks, now I have something else to tryout..


--CroW