PDA

View Full Version : Extracting DTivo 3.1



underpaid
12-19-2002, 10:31 PM
I've been going through the "stickies", but I still can't find a solution for extracting .ty streams from my DSR6000 running 3.1.

Up til now I am able to get the mfsstream module working in TiVoWeb. The save-as dialog comes up, but it will not download properly. It only produces .ty files of 0 bytes.

There are alot of different versions of the mfsstream files and I still haven't been able to find the right combination.

Have anyone been successful with mfsstream and Dtivo running 3.1 ?

If so, which version of the files do you use ?

mrblack51
12-20-2002, 03:37 AM
I have mfsstream running on my dtivo. it sounds like you found the version for 3.x units, which is importat. the other thing you should check is whether you applied the noscramble patch to your kernel. the patch was posted by alphawolf in the tivo extraction forum

underpaid
12-20-2002, 05:01 PM
Yes, I do use noscramble.o, the latest version I was able to find on this board. I use:
insmod /var/hack/noscramble.o in my rc.sysinit.author and /var/hack/tivoweb-tcl/tyhttpd 2000 4 >> /dev/null &
As the TivoWeb interface is OK, I am sure it is the extraction itself (msfstream ?) that probably is the culpit or maybe the noscramble.o version. But I do not get any error when loading the noscramble.o.

I am still a bit uncertain on the tyhttpd and how to use it correctly. If you have this working, what are the versions and where are they located on the TiVo (directory) ?

is it like this:
mfs_stream (on /tivoweb-tcl ?)
tyhttpd (on /tivoweb-tcl ?)
mfsstream.cfg (on /tivoweb-tcl/modules ?)
mfsstream.itcl (on /tivoweb-tcl/modules ?)

Are there more files involved like tserver_mfs ?

AlphaWolf
12-20-2002, 05:14 PM
I don't believe the module is compatible with 3.1. If it is, your going to need to use insmods -f option, or else the module wont even load.

zeek
12-21-2002, 11:27 AM
The noscramble mod is indeed compatible with 3.1, I'm running it- it must be the -f option which is causing it not to load...


zeek

ArcticGabe
12-21-2002, 11:42 AM
underpaid,

Let me tell you my story. Like you, I've been doing more lurking than posting since I'm quite new to all of this. Here is my setup for getting Ty streams from my SAT-T60 running 3.1:

1) Using TyTool Alpha #5 (http://www.dealdatabase.com/forum/showthread.php?s=&threadid=14838&highlight=Tytool+alpha) with tserver_mfs5. NOTE: this only runs well when I boot to WIN98, and crashes when I boot to WIN2K.

2) Using NowShowing.tcl (http://www.dealdatabase.com/forum/showthread.php?s=&postid=51751&highlight=tytool#post51751) from tivobot. The original NowShowing.tcl does not work with my setup (don't ask me why, I'm too new to this).

3) Using noscramble.o (http://www.dealdatabase.com/forum/showthread.php?s=&postid=34957&highlight=noscramble#post34957) from kowesoft. I installed this with the following command as suggested by AlphaWolf without complaints from TiVo:
insmod -f /lib/modules/noscramble.o

So using this, I was able to get some Ty streams, but I found that I got 0 byte files when done. Then I did some more reading and found another post from AlphaWolf that solved my problem. He said that this will only work if you recorded the show with the noscramble module loaded prior to recording.

So this is where I am to date. I can get Ty streams, but whoooh it takes forever to download a single file (approx. 0.2 Mb/sec). Now, I'm doing more lurking to find out the next steps for getting this stuff onto CD and speeding up the download process (if anyone can point me in the right direction, I'd be grateful.)

Good luck, underpaid. Hope this helps.

Thanks to everyone else (especially jdiner) for getting me this far.

underpaid
12-21-2002, 01:35 PM
Thanks for putting this together, there are sevral version of the files and allthough I had them all before, your combination is the one that works on my DSR6000 DTivo.

Used the method above and got my .ty file which I also parsed using tytool.

I guess I settle with this, I't just as easy as using TiVoWeb.....

So now it's getting this to DVD/CD that is the challenge, but there are 100's ;) of different good methods for this in this forum.

:D

PS: I'm getting approx 1.3 Mb/s when extracting directly to .m2v and .m2a files.

AlphaWolf
12-21-2002, 06:44 PM
underpaid: it was the insmod -f /lib/modules/noscramble.o that fixed it, tivoweb is going to work just the same.

underpaid
12-21-2002, 08:41 PM
I am not so sure. I just extracted a stream that was recorded two weeks ago. That's long before I was aware of the -f parameter, so it appears that it was indeed loaded correctly. Anyway, thanks guys for all the help. I am happy streamin' at the moment.

Doing a lille VCD test right now :p with TMPGEnc......

ArcticGabe
12-22-2002, 10:06 AM
Hey let me know how the VCD thing works for you using TMPGEnc. I've been busting my brain trying to figure this thing out.

Thanks!!