PDA

View Full Version : Tytool - Failed to connect



metaldog99
01-02-2003, 02:55 PM
Can anyone point me in the right direction? I have been searching through an reading all the posts re: extraction and TyTool, but have gotten nowhere in just getting Tytool to see my DTivo unit. I'm missing something obvious here, but need some help in figuring it out. I don't know what else to try.

I have been trying to extract from my DTivo for over a week now using the latest TyTool, and cannot connect using the TyTool client.

I can connect and extract using TivoApp fine. I've extracted up to a 4.4g tystream.

I am running Windows XP Pro SP1 on AMD Athlon 1800+ with 512M and 120g.

DTivo
2.5 Extreme
TurboNet installed
Kraven's upgrade

Here are the outputs:

From DTivo:

bash-2.02# ./tserver_mfs5r2
Doing the Lowest PriorityFix...
Priority set...
Waiting for an incomming connection!

From TyTool:

Ready...
Reading list from the server...
Clear Now Showing List...
Connecting to '100.0.0.100'
ERROR: Failed to Connect!

DTivo is on home network through two Linksys switches which connect to internet through Cisco 678 router (DSL connection)

I can Telnet and FTP into the DTivo from all other PC's connected to network.


*** rc.remote-login ***

#!/bin/bash

ifconfig net0 10.0.0.100 netmask 255.255.255.0
route.tivonet delete default 2>/dev/null
# route.tivonet add default gw 10.0.0.1 netmask 0.0.0.0 dev net0


echo "Starting Telnet"
tnlited 23 /bin/bash -login &
....................... (rest is standard per Kraven upgrade)

captain_video
01-02-2003, 04:05 PM
Could this be your problem:

From Tytool -

Connecting to '100.0.0.100'


From #!/bin/bash -

ifconfig net0 10.0.0.100 netmask 255.255.255.0

Shouldn't the two addresses match (i.e. 10.0.0.100 and 100.10.10.100)? It looks like you've got a mismatch between IP addresses used by TeraTerm and Tytool which is why you're not connecting. TeraTerm has the correct address but Tytool isn't set up for the same address. Change the address in Tytool to 10.0.0.100 and you should get connected.

metaldog99
01-02-2003, 06:36 PM
Wow - can't believe I missed that! That's what kind of week it's been tho...

Thanks for the quick help!