View Full Version : HELP! Alias with tytool gone wrong

01-12-2003, 03:30 AM
I had tytool running fine until i tried to get it to run using an alias:

alias tytool='cd /var/hack ./tserver_mfs'

now when i try to run tytool from bash it says:

bash-2.02# ./tserver_mfs
Doing the Lowest PriorityFix...
Priority set...
Bad binding in the server: Address already in use

How do i fix this??

01-12-2003, 04:47 AM
that happens to me sometimes, have you tried rebooting the tivo? it works for me

01-12-2003, 06:14 AM
Rebooting seems to have fixed it.... thanks for your help

01-12-2003, 08:12 AM
Originally posted by gnome
Rebooting seems to have fixed it.... thanks for your help

this is a result of tserver_mfs already/still running - you can do a

ps aux

to see what PID it is and kill the proccess, then try re starting...

root 158 0.1 19.1 17400 2664 ? S 20:32 1:39 ContextMgr eve
root 189 0.0 0.0 0 0 p0 SW 20:31 0:00 (bash)
root 190 14.2 14.3 2876 2000 p0 D 06:43 49:24 ./tserver_mfs
root 198 0.0 0.0 0 0 p1 SW 20:31 0:00 /bin/bash -login

in this example you would

kill -15 190

(PID) being the proccess ID number you found related to tserver_mfs.

The cause of this is generally the result of exiting from a telnet session without stopping tserver_mfs. I have had mixed results with this between my TiVos my DTiVo seems to 'quit' the tserver_mfs process, when I [ctrl-c] then exit my session with an exit. But my SA does not(always). Hence having to use the 'kill' method prior to restarting. rebooting does the same thing - only wasting allot more time!