PDA

View Full Version : Wooly or any others..I get no audio when using IFOEdit



RxMan
01-24-2003, 01:37 PM
I followed these directions:

HowTo for IFOEdit:

1. Grab the .ty file from the Dtivo
2. Use my Bat file
3. Drag-n-drop the .ty file onto the bat file
4. GOP Edit the sucker
5. quit the GOPEditor
6. Grab a beer
7. come back, the bat file will be done
8. Demux the file (use TMPGEnc, it's very good). Create an .m2v and an .m2a
9. Run IFO Edit v.96Beta1
10. DVD Author (at the top)
11. Add the .m2v in the Video Stream (by clicking the right button)
12. Add the .m2a in the Audio Stream (by clicking the right button)
13. If you're adding another set of streams, hit Add Title (at the top) and repeat #11 and #12. When that's all done, select a desitination directory, hit ok at the bottom
14. When IFO Edit is done, quit IFOEdit
15. Run IFO Edit again, go into the destination directory you defined in #13, and open the VTS*.IFO. Hit the "Get VTS Sector" button, hit okay until everything is updated. Save the file.

That's it. You now have the contents of a Video_TS folder ready to burn.

I tested the folder in PowerDvD and get video but no audio. Am I missing something? I basically took all of the files that IFOEdit created and put them in a VIDEO_TS folder.

RxMan
01-24-2003, 02:45 PM
I am trying the file again. The mpeg file from GOPEditor plays fine (with audio) in Window Media Player. I must have messed something up in the de-mux or IFOEdit step.

RxMan
01-24-2003, 04:29 PM
OK. I tried again. I used demux in TMP and got a m2v and m2a. I then followed the instructions for IFOEdit. I was left with the following files.

Video_TS.bup
Video_TS.ifo
VTS_01_0.bup
VTS_01_0.ifo
VTS_01_1.vob
VTS_01_2.vob

Notice that I do not have a VIDEO_TS.vob nor a VTS_01_0.vob. I'm not sure were the problem is.

When I de-mux using TMPGenc, do I need to change any settings? I came out with a .m2v and a winamp media file. IFOEdit accepted both of these.

HELP? :)

Wooly
01-24-2003, 06:50 PM
You're fine from a structure setup - you should NOT have a VIDEO_TS.VOB nor a VTS_01_0.VOB - these files typically are intro's and menu information. Seeing as we didn't make a menu (hmm...that makes me think of a menu solution...gotta work on this one) they should not be present.

Now, if you have PowerDVD (or WinDVD for that matter) please drop the VTS_01_1.VOB file onto the screening area of one of those programs when running. In PowerDVD, right click and select "show information". This should show you some basic info. If you get sound this way, the problem is in your VTS_01_0.IFO file. Open it in IFOEdit and look at the Audio section (go to http://www.doom9.net for details on IFOEdit, it's all there). Suffice it to say, double click on the audio stream and you can manually modify attributes of how an audio stream is loaded via the DVD player.

If it DOESN'T play audio...hmm...honestly, I don't know, but if you wanna burn it to a DVD I'll be happy to take a look at it (or provide an FTP for me to download the whole structure).

Truthfully, there are only so many things that can go wrong with this. Try Demuxing the VOB via TMPGEnc and see if there's audio. If there is, then there's something wrong with the .ifo files, as that means that the audio is there.

Or...could be the codecs on your system (but that's pushing things).


Originally posted by RxMan
OK. I tried again. I used demux in TMP and got a m2v and m2a. I then followed the instructions for IFOEdit. I was left with the following files.

Video_TS.bup
Video_TS.ifo
VTS_01_0.bup
VTS_01_0.ifo
VTS_01_1.vob
VTS_01_2.vob

Notice that I do not have a VIDEO_TS.vob nor a VTS_01_0.vob. I'm not sure were the problem is.

When I de-mux using TMPGenc, do I need to change any settings? I came out with a .m2v and a winamp media file. IFOEdit accepted both of these.

HELP? :)

RxMan
01-24-2003, 07:06 PM
Thanks for the reply. I noticed that when I open TMPGENC it says that MPEG-2 has expired. Not sure if this matters or not. I am trying to correct that now.

I will try your suggestions as well.

Do I use simple demux or demux in TMPGEnc? Do I change any settings or just leave it at MPEG-1 System (automatic)??

RxMan
01-24-2003, 08:30 PM
I love replying in mw own thread to myself.....wwweeeee!!

OK. In IfoEdit under 'DVD Author' , Do I select 'Author New DVD' or "Create Video_TS.IFO'??


Thanks!

archieellis
01-24-2003, 08:54 PM
I was having the same exact problem. I saw in another post someone had some trouble, so I did roughly the same thing they did....I used BeSweet to convert the mp2 (from TMPGEnc) to ac3, while also changing the sample rate to 48Khz. That solved it.

Wooly
01-24-2003, 11:51 PM
Author New DVD


Originally posted by RxMan
I love replying in mw own thread to myself.....wwweeeee!!

OK. In IfoEdit under 'DVD Author' , Do I select 'Author New DVD' or "Create Video_TS.IFO'??


Thanks!

Wooly
01-24-2003, 11:54 PM
Mpeg-2 Expired - possible that the Demo has expired. 2 solutions for that, one involves money. You make your choice there.

Simple De-Multiplex is best, in that it's easier.

Whenever faced with this, I choose Mpeg-2 VBR. There may be a difference between that and Mpeg-2 SVCD, but that's a discussion for someone who's more knowledgeable than I.


Originally posted by RxMan
Thanks for the reply. I noticed that when I open TMPGENC it says that MPEG-2 has expired. Not sure if this matters or not. I am trying to correct that now.

I will try your suggestions as well.

Do I use simple demux or demux in TMPGEnc? Do I change any settings or just leave it at MPEG-1 System (automatic)??

zeek
01-25-2003, 05:59 PM
RxMan-
Did you get this resolved? I'm having the same problem and have been following this thread hoping for an answer!


zeek

RxMan
01-25-2003, 11:26 PM
Nope. I never did. I tried the whole process together on a different movie and got the same result. Then, I tried yet again on a 30min show which I cut out about 20min right in the middle to save time. This time IfoEdit puked on it and I could even get it to start the process.

I just gave up for now.

The exact same files trasported into SpruceUp and worked flawlessly.

zeek
01-26-2003, 07:09 PM
Wooly (and/or others...)

I also have no audio, no matter what I do in TMPenc.
If you have time, would you mind taking a look at my DVD files and telling me if you see where I went wrong? I viewed the files in IFOedit and can't find any audio information.

VIDEO_TS folder:
video_ts.bup (http://zeek.dynip.com/DVD/video_ts/video_ts.bup)
vts_01_0.bup (http://zeek.dynip.com/DVD/video_ts/video_ts.ifo)
vts_01_0.bup (http://zeek.dynip.com/DVD/video_ts/vts_01_0.bup)
vts_01_0.ifo (http://zeek.dynip.com/DVD/video_ts/vts_01_0.ifo)
vts_01_1.vob (http://zeek.dynip.com/DVD/video_ts/vts_01_1.vob)
vts_01_2.vob (http://zeek.dynip.com/DVD/video_ts/vts_01_2.vob)


AUDIO_TS folder:
(exists on the DVD but is blank)

This was supposed to be 'Boxing Helena' recorded from IFC. :)
thanks,
zeek

zeek
01-29-2003, 10:05 AM
For those who utilize the SEARCH function in the future and find this thread: Here is Wooly's response he posted in the other thread. The fix worked for me!
(To my future self: Hi!)



====================
Re: Re: Re: Sound Problems
No need - you got me thinking about some things, and I went through a couple of files, trying to recreate your issue - and I was sucessful. Unfortunately.

Edit the .ty. Create the .mpg. .mpg plays just fine in PowerDVD, no weirdness. DeMux it. No problem, video shows up fine as a stream, audio plays fine as a stream. Go into IFOEdit, go to create a DVD, and BAM, POW, WAMMO, there's no auto-detection of the Audio type. I'm killing myself to figure out the problem, and I realize that Jdiner's vsplit -m option has somehow created an audio problem in that the header is un-recognizable by IFOEdit. THIS IS WHY you have no audio. Now, we need to review the Audio file for the reason why.

I found out, however, that if the file is run through BeSweet and transcoded, the original audio file has several MP2 errors in it along with a strange header I've never seen before that is apparently an illegal header. BTW, here's the BeSweet command you'll need:

"C:\AV\BeSweet\BeSweet.exe" -core( -input "f:\Work\Stargate SG-1 - Smoke and Mirrors.ty.mp2" -output "f:\Work\Stargate SG-1 - Smoke and Mirrors Edited.ty.mp2" ) -azid( -c light -L -3db --maximize ) -ssrc( --rate 48000 ) -2lame( -m j -b 224 -e )

As you can see, the file I used is "Stargate SG-1 - Smoke and Mirrors.ty.mp2". run your audio .mp2 file through this command before running IFOEdit and you'll be golden shower.

Josh, I have both the original .mp2 file and the corrected .mp2 file if you wanna review them. Lemme know how to get them to you. They're 70 megs each. Following this process provides sync every time in my experiments. I don't see a large quality loss either. Clearly, this is NOT a permanent solution, but rather a stop-gap. Remember, folks, we are dealing with Beta code here so everyone help Jdiner out with this.
==================





zeek

Slowride
02-20-2003, 12:24 AM
Can anyone help point me to where I can download/buy ifoedit 096, I hear so much about it, but I have been unable to find it.

Thanks in advance,
Slowride