PDA

View Full Version : mplex help



2ride
02-09-2003, 02:41 PM
I have been trying to use mplex to mux a 5 gig video file with a 250meg audio file. Obviously the resulting output should be aroung 5.5 gig. Using mplex it always stops and hangs when the output reaches 2 gig.

I have used the -S 0 flag with no luck

I am running winxp pro ( ntfs )

I have tried -S 8000

i am using the cygwin port of mplex version 1.6

After it hangs for awhile i get the following message repeated multiple times:

!
++ WARN: [mplex] End of component bit-stream ... seeking next
++ WARN: [mplex] Failed to find start of next stream at 172399237 prev 172398662
!



Am I missing something obvious here?

example run line:

mplex -S 0 -O 003 -f 3 -o output.mpg input.m2v input.m2a

TIA

2ride

MrBassMan
02-10-2003, 06:18 AM
Try this command instead:

mplex -S 0 -O 003 -f 3 -o output_%d.mpg input.m2v input.m2a

The %d is needed because mplex stops output at the legal maximum size of a file for the format (-f) you have specified. If it sees a %d in the output name it replaces it with '1' for the first file '2' for the second etc.

2ride
02-10-2003, 12:44 PM
I couldn't figure out for the life of me how to use the %d. The usage statement was all I had to work off of and it wasn't very clear.

I am testing this now.

Will post results when available

2ride

2ride
02-10-2003, 11:32 PM
Still can't get past 2gig output with mplex

this is the last error i see

**ERROR: [mplex] INTERNAL ERROR: additional data required but no free space in
nput buffer

There is a -b option to set video buffers but it doesn't seem to work. When I use it I always get the usage statement returned.


Has anybody out there used mplex to multiplex over 2gig?


TIA

2ride

Gruph
02-11-2003, 02:52 AM
Check out the tyremux sticky thread. There are a few people that have been working to get it to support files > 2Gigabytes. I'm not sure exactly what kind of progress they made. You'd have to search a little hard because it's not the focus of the thread.

I am running mplex on both a PC and a Mac running OS X. For any larger files, I use command line on the Mac so it's not a big deal for me.

If you have access to a linux box, you can use mplex on that as well as that will support files >2GB too.

One more option is deal with the 2GB files for now and wait until Olaf and gang has built in muxing functionality into tydemux (then it will be tyremux). Should be very cool. They have said that it WILL support muxing of files greater than 2 GB in operating systems that support it (win2k and winxp - not sure if winnt is included but would guess so).

If you plan to save it to a dvd, they only support I believe 1Gig files anyway... just a thought.


-Gruph

Gruph
02-11-2003, 02:57 AM
Originally posted by MrBassMan
Try this command instead:

mplex -S 0 -O 003 -f 3 -o output_%d.mpg input.m2v input.m2a

The %d is needed because mplex stops output at the legal maximum size of a file for the format (-f) you have specified. If it sees a %d in the output name it replaces it with '1' for the first file '2' for the second etc.

Instead of this, you could try the following:

mplex -S 2000 -M -O 003 -f 3 -o output_%d.mpg input.m2v input.m2a

Please note the -S 2000 and the -M. The -M is telling it to segment the file. the -S is telling it how big. Then the %d will increment, starting at 1 for each file. If you want to do 1GB files, you could use -S 1024 instead. Granted it would not be as convenient as one large file, but at least you'd be able to play with it.

-Gruph