View Full Version : need alittle help with...

03-06-2003, 04:45 AM
This is my setup

Running with a hard drive that has 2 partitions on it a NTFS and a Fat32 they read in Windows XP as

C: ( E: ) ntfs 8.87used 1.98gb unused

F: fat32 3.83 unused

I'm useing these inscructions

8. Mount the Windows drive by using the following command:
mount /dev/hda1 /mnt/c

9. Verify you can "see" the Windows drive by doing an ls /mnt/c and you should see a directory of your Windows C drive. Also verify you have at least 2 gigs free on that partition by using the df command.

Should I be useing "mnt/f" when I tried that is gave me a reply that there was no F or something damn I should have wrote that down...?

Again this is one hard drive with two partitions c: ( e: ) and f:

Also when I "/mnt/c" it says this is a read only drive I'm guessing this is 'cause its a NTFS format??? Thats fine how do I mnt my Fat32 drive?

I'm useing this how to
Tivo howto http://www.tivocommunity.com (http://www.tivocommunity.com/tivo-vb/showthread.php?s=&threadid=90268)

Also one other thing when I try the 1s command it says that there is not command like this...

I'm I missing something simple?

thanks in advance

03-06-2003, 11:26 AM
change hda1 to hda3 and see if that works.

03-06-2003, 01:15 PM
what should I mount ( F: ) ?

03-06-2003, 02:03 PM
the drive letter in windows means nothing, as it is an arbitrary label for a given windows compatible partition. linux only cares about partitions

mount /dev/hda3 /mnt/c

the /mnt/c is just where you want to mount your drive. it has nothing to do with drive letters, nor is there anything special about /mnt/c. /mnt/c is just a directory. you could just as easily change it to /mnt/d, or /mnt/monkeys_like_bananas if you wanted, so long as those directories existed

the /dev/hdX# is the drive and partition. hda is primary master, hdb is primary slave, hdc is secondary master, and hdd is secondary slave. the # is the partition number. your drive probably has 3 partitions on it:

1 - primary partition, most likely your ntfs partition
2 - extended partition, used to hold logical partition
3 - logical partition, most likely your fat32 partition

03-06-2003, 06:56 PM

but that doesn't explain this at the

/# mount /devhda3 /mnt/c

gives me this response

/dev/hda3 : Success
mount: you must specify the filesystem type

what the heck does that mean

03-06-2003, 07:02 PM
it means the linux system can't figure out what type of partition you are trying to mount. it may be because your system's partition for fat32 is not hda3. type cat /proc/partitions and you should see a list of partitions. try mounting each one to see if it works. if its not the one you want, then do a umount /mnt/c or umount /path/used/in/mount/command. note: you can't be in the directory (or a subdirectory of) where you successfully mounted a partition when unmounting.

03-10-2003, 04:55 AM
Ok so lets see if I can get this all right...

First I'm wondering why when I type:
1s /mnt/c at anytime it says there is no such command... just is odd to me

Anyway moveing on

MrB you help has helped me much in explaining the way things work but I'm still alittle confused, this is whats happening

After I did as you said and tried the cat /proc/partitions I found I had this

major minor #blocks name
3 0 13356000 hda
3 1 9309636 hda1
3 2 4040347 hda2

I tryed hda2 and that seems to be the partition I need. I think this because when I

#/mount /dev/hda2 /mnt/c

I get no response from the system at all just another #/ prompt
BUT If I do a


I get this response

Filesystem 1k-Blocks Used Available Used Mnt
/dev /ram0 15863 9792 6071 62% /
dev /hda2 40224606 255604 3769002 6% /mntc

Good news is that hda2 seems correct because I saved a Tivo2.bak there ruffly about 250ish mb that someone wonderfully told me where to find and download (sorry to anyone reading this thread looking for a Hdvr2.bak, I can't pass on where I got it to anyone reading cuse I don't know how much bandwidth they have and its a large file you'll have to ask for it in a post and hope for a PM, again sorry...)

how do I check to see if this is the right local, I thought 1s /mnt/c was the command but thats not giving me anyresponse...

Also if I
#/ umount dev/hda2 /mnt/c

its says that mnt/c is not mounted.... that the same as its now unmounted or that it was never mounted...

AND finnally

I'm useing JohnDeaths mfstools2iso should I use a different one??? It was the one they said to use in the howto

thanks again.....

03-10-2003, 04:57 AM
hahahaha I just spent about 15minutes spaceing all those color text so they would be neatly in columes and thats what I get, guess spacebar don't mean nothing to http duh anyway I'm sure you'll get the idea

03-10-2003, 05:52 AM
Orangejaylove is stupid.... just reading stuff on 9thtee and realized that 1s is not 1s at all but ls.... (ls said same as Dir in Dos) thats LS chz and crackers!!! anyone want to smack me just add a *smack* post to this thread!

03-10-2003, 06:04 AM
and with the ls command I can now see my file on that drive although it has a * next to it whats the * mean...

everything ok now? am I set to go...?