PDA

View Full Version : Need some help with TyTool



GLS
03-23-2003, 03:09 AM
I'm getting started with TyTool using the helpful step-by-step howto posted at http://tipster.stormrad.com/tivo/extraction.html.

However, I've run into a problem--it gets stuck when I go to get the Now Showing list. I get the following message:

Ready...
Reading list from the server...
Connecting to '192.168.0.200'...
Connected...
Getting NowShowing data...
Sorry.. Could not obtain the list.

I'm confused... my only theory is that maybe the howto I'm reading is for SA TiVos, and I need to be doing something different for my DSR6000?? I'm really reaching though. Any suggestions? Thanks!

mw2000
03-23-2003, 12:51 PM
Are you running tserver through telnet?

GLS
03-23-2003, 04:47 PM
Yes, and it gives the 'waiting for incoming connection' message.

newbie
03-23-2003, 05:05 PM
Are you sure the IP address is correct?

GLS
03-23-2003, 05:11 PM
IP address is correct.

Tor
03-23-2003, 10:19 PM
The problem is in NowShowing.tcl. It is looking for "3.0" in your version string. I don't know tcl but I was able to get mine to work by changing this line:

if { [PrefixMatches "3.0" $tivoswversion] } {

to

if { [PrefixMatches "3.0" $tivoswversion] || [PrefixMatches "3.1" $tivoswversion] } {

There is probably another way to do this but I don't have the tcl expertise to make it happen.

GLS
03-24-2003, 02:53 AM
Worked perfectly. Thanks Tor! And thanks to everyone who worked on these tools and allow newbies like me to enjoy the fruits of their labor.

One more question--when I'm through extracting, can I just close the telnet session? Also, does tserver continue running/do I need to shut it down somehow?

mw2000
03-24-2003, 11:12 AM
I always close the telnet session after downloading the ty files and then use tytools to make keys etc.

It does seem from my experience that tserver authomatically closes when the telnet session ends.