PDA

View Full Version : NFS on Tivo



mavrcksd
04-24-2003, 10:40 PM
Can anyone point me in the right direction on how to use / setup NFS on Tivo to dump files to a WinDOZE 2k server? or vice versa?

Thanks

tweaky
04-25-2003, 06:47 AM
In an effort to help yourself, use the search button.
Here (http://www.dealdatabase.com/forum/showthread.php?s=&threadid=18245&highlight=setup+nfs) is just one thread that might help out.

You will need to set up a nfs server on the windows box first. Then mount that shared directory on the tivo.

mavrcksd
04-28-2003, 10:18 AM
I went to the area that Tweaky pointed me out to: and the guys over there were having issues as well:

They pointed out they changed their IPTABLES. I'm getting the same RPC error as they were.

I am a moderate user of LINUX: and still learning more and more every day.

Can someone help me out in modifying/ adding those user rules to allow the NFS to go out through my tivo to access my winDOZE box?

I'm running an SA tivo with turbonet and 3.0 software. 80GB B drive, and orig Tivo A drive.

Thanks again.

Torg
04-28-2003, 04:13 PM
Win2K is about as braindead as you can get with regard to filesystems. About the only thing you can do is run a third party (read unstable) NFS server on it.

Conversly you can mount its shares via the smb module. Then mount a Win2k share.

smbmount \\\\win2kserver\\C$ /mnt/C -o username=whatever

mavrcksd
04-28-2003, 09:55 PM
I'm getting the error
Error: Unable to start smbfs, exiting...

when i try to do the command:

smbmount //192.168.1.112:/tivo /mnt/C -o username=tivo

ARGH

Torg
04-28-2003, 10:04 PM
1) Is there a user tivo on the win2k box?
2) What is the name of the Win2k box?

smbmount \\\\NAME\\C$ /mnt/C -o username=user

where NAME is the name of the win2k box and user is a valid user ON the win2k box.

mavrcksd
04-28-2003, 10:08 PM
Yes:

the acct name on the windoze box is tivo and pw is tivo as well.

when I do the command :

smbmount \\\\BEN\C$ /mnt/C -o username=tivo
i get the error

"usage: smbmount //server/service mount-point [options]
try 'smbmount -h' for more information
bash-2.02#

I have tried doing the insmod smbfs-2.0.1.o before and it gives me the error "kernel module version mismatch"

HELP! :)

Torg
04-29-2003, 12:00 AM
Then try it with forward slashes instead

smbmount //ben/C$ /mnt/C -o username=tivo

The \\ means use one slash \

mavrcksd
04-29-2003, 08:34 AM
Sorry for my ignorance on the backslashes:

I'm getting the error : unable to start smbfs, exiting.....

i'm rebooting the tivo and going to attempt it again:
and try the actual IP address.

same error:

"unable to start smbfs, exiting...."

I tried the -U tivo for the "options" to pass the username tivo.

hmm - this is different error than the mount point error: now it just seems that it doesnt have the service running.????

lmurray
04-30-2003, 08:14 PM
try using search a bit for help on smb.

Here's what I do:

insmod -f smbfs-2.0.1.o
smbmount //trash/CDRIVE /mnt/windows/ -I 192.168.3.2 -P welcome


where trash is the name of my windows box
CDRIVE is the share
/mnt/windows is the directory on the tivo to mount to
192.168.3.2 is the ip address
and welcome is my password


hope this helps

-lloyd-

mavrcksd
05-01-2003, 09:43 AM
in doing the command:

smbmount //BEN/CDRIVE /mnt/windows -I 192.168.1.10 -P welcome

Changes I made to allow this:

changed guest account password to welcome
the 192.168.1.10 is the IP of the tivo???? correct?

I shared the C drive of the windoze box as CDRIVE with everyone full control

BEN is the name of the windows box: I thought that it could not resolve names to IP's?

however I still get the error "Mount error: invalid argument"

If i leave off the -I and everything after it - I get a password prompt. I enter in the password for guest, etc. and nothing.

I have setup a guest account, pcguest, etc.

HELP!

lmurray
05-03-2003, 12:03 PM
the ip address is the ip address of the windows box with the share.

did you run the insmod command first ?

-lloyd-

mavrcksd
05-03-2003, 02:15 PM
well

now what happends is

when i do a mkdir /mnt/<dir>
that is alright

then i do the command smbmount //BEN/CDRIVE /mnt/<dir that i created> -I 192.168.1.50 (windoze box IP) -U tivo -P tivo

it goes back to the BASH prompt

but when i do a ls /mnt/<dir> it shows 0 files

and when i try to do a copy of a file to that directory it doesnt copy it to the windoze box, it just puts it in the folder that i created..??

cyclops_57
06-02-2003, 08:56 PM
I have 3 DirecTiVo v.2.5.1, and I was wondering if it is possible to have all the TiVo's do a NFS mount to a centralized NSF server for the "Now Showing" files?

I apologize for my limited knowledge of how the TiVo stores its files. Just a thought I had. I'm sure if it was easy or possible someone else would have already have done it.

Torg
06-03-2003, 04:09 PM
Not unless you are talking about a centra dump site. The NFS server would have to know the filesystem in order to mount it. Since Tivo stores its data in its own filesystem, no.