PDA

View Full Version : 2.52 and Tyserver



Y2JProd
04-30-2003, 09:16 PM
After upgrading my tivo to 2.52 to fix a locals problem, tyserver and tyindex are no longer functioning correctly (I reinstalled them after the upgrade).

They are in the rc.sysinit, but do not get loaded when the tivo boots.

If I run them manually, the processes exit abnormally during an extraction.

Actually it does not look like I can get anything in the rc.sysinit to run properly after upgrading to 2.52. I do have xplusz running as well if that makes any differences. I only have telnet, ftp, nophone, noscramble and addloc running through xplusz.

SR712
04-30-2003, 10:36 PM
If I remember correctly, the rc.sysinit that comes with the 2.5.2 upgrade ends with a

exec < /dev/ttyS3 >& /dev/ttyS3; bash --login

I believe it was generally believed that that last statement never exited the script. That might be why the rest of the commands don't execute after it. I changed mine to the old way of doing things

/bin/bash --login < /dev/ttyS3 >& /dev/ttyS3 &

and it would exit correctly. Might be worth a try.

Y2JProd
05-01-2003, 02:04 AM
That worked. And I seem to be able to extract OK now.

Thanks again!