PDA

View Full Version : Hex edit issue



NooBLisa
05-07-2003, 03:13 PM
HDVR2 with 3.1.U5-01-2-151

I have been having trouble editing a file with my PC hex editor (I think).

I have been sending the file to my PC editing it in a hex editor sending it back and upon each boot I have my hackinit file replacing it with the original and setting chmod 777 to the file attributes. For some strange reason the Tivo boots up fine the first time (seems the file is not being replaced) and I still don't get my desired results from my editing. However the second time I reboot I get bash but just hang at the Welcome screen. If I replace the hex file with the original and # out my request to replace the file in hackinit I notice I boot with no problem. So I'm lead to believe that the system does not like the file I edited. Is it okay to edit this file in Windows (XP NTFS) and send it back via serial? Is that my problem? If so can someone reccommend a hex editing utility I can use when booting with MFSTOOLS2 so I can make my edit there and save before replacing the drive back into the unit? I was thinking maybe this utility is included in MFSTOOLS2 but was not sure.


Thanks bunches ;x

Info Ho

Logandros
05-07-2003, 03:29 PM
I have not done the edit that you are referring to, but have you double-checked your edits in the file. I would assume anything wrong in there would cause similar symptoms.

PS - nice to see a girl taking an interest in such hobbies .. the future is bright !

NooBLisa
05-07-2003, 03:31 PM
I have triple-checked.

PS - I have enjoyed it here !

Info Ho

mrblack51
05-07-2003, 03:43 PM
if you replace anything on the root partition (such as rc.sysinit)and you are using bash_env, then your tivo will reboot once every time it boots. this is because the first boot has signatures which fail the check, so it deletes the 'bad' files and replaces them if possible, then reboots. the second boot will have everything pass the check, and will go into the rc.sysinit.

NooBLisa
05-07-2003, 03:54 PM
Not sure if there was an answer to my question somewhere in there mrblack51 .. if there was thank you .. however it went right over my head.

Still need direction regarding my hex editing procedures and if I'm at fault. ;x


Info Ho

mrblack51
05-07-2003, 04:37 PM
you can edit any file on any system as long as you use the proper editor. i prefer either ultraedit or textpad, since they have good support for unix files and such.

when you transfer the file to the tivo, make sure you are putting it in /var/hack or some subdirectory, and that you are putting the proper permissions on the file you upload. this goes for hackinit, which should be executable, and whatever else you put there.

NooBLisa
05-07-2003, 04:44 PM
I was not using either of the hex editors you mentioned, I was doing everything else the same though. Hopefully the app I was using is the problem/ I will try one of the ones you are more comfortable with ...

May I also ask

stty sane
stty 115200

can that be added after

/bin/bash < /dev/ttyS2 >& /dev/ttyS2 &

to help speed up my transfers ? I tried it once and adjusted hyperterminal accordingly but could not get a bash prompt so I removed it.

Info Ho

Logandros
05-08-2003, 03:31 AM
I know exactly what your problem is. Use ultraedit all your troubles will be wHisked and rUbbed away! Not sure about stty I use USB ethernet that I finally found works Belkin F5D5050.

NooBLisa
05-08-2003, 05:24 AM
Worked like a charm! TH ank YoU Logan

;x

Info Ho

txag93
05-08-2003, 11:43 AM
I too have the stty problem

I tried putting it into a tcl script with a long sleep before calling it from hackinit, I tried calling stty sane first, nothing.

If I run the script from the bash prompt it works great, but it won't do it automatically from the hackinit.

Any help in getting stty 115200 executed automatically with each boot?