PDA

View Full Version : vsplit3 "finishes" half way through file?



h0trod
06-17-2003, 12:04 PM
I have an appx. 5.5Gb .ty file that I'm trying to split into seperate audio / video streams so I can upsample the audio before burning to DVD. Problem is, vsplit conks out somewhere in the middle, leaving an m2v of just over 2Gb. (I am using an NTFS formatted drive, where the 5.5Gb .ty lives, so I'm not hitting a Windows file size limit.) There are errors along the way like:

Unknown PES packet. Fix it dear henry...
type = 0x0

Found an OOB packet... The Video Diff is: 02:05:11.122
BBB the PTS was bad, but the new SEQ check lines up|!?
Found an OOB packet... The Audio Diff is: 00:00:00.072
It is in sequence... Everything is fine...

It appears to continue through those, but in the end I'm left with a truncated m2v file. I'll attach the output from vsplit..

Any ideas what might be going on? Any other tools to try, perhaps?

Thanks!

captain_video
06-17-2003, 02:13 PM
Errors like the one you posted are quite common so I wouldn't be that concerned about them unless that's all you see. If you're running anything else on the Tivo while you're extracting TyTool will sometimes simply quit or even cause the Tivo to reboot. If you're using a DTivo, try placing it in standby mode prior to extracting. This stops the video from being buffered to the hard drive and frees up resources for the CPU.

h0trod
06-17-2003, 02:37 PM
Captain_Video,

Believe me it took more than a few tries to get the .ty successfully off the tivo using tytool - but I have been able to do it. My problem currently lies in the "split", which I am trying to perform outside of tytool (well, I have tried it both within tytool and standalone, and predictably enough, have had the same result with both.)

Thanks,
Jay

captain_video
06-17-2003, 09:18 PM
The splitting function actually occurs after the ty file is transferred to your PC so it may be something on the PC side that's not behaving itself with TyTool. Try shutting down any unnecesary applications that may be running in the background on your PC.