PDA

View Full Version : Tivoflash failed, now I'm in the dog house :(



Hagar
07-30-2003, 11:19 AM
After years as a dedicated TiVo user, I finally decided that it was time to upgrade my Hughes Series 1 DTiVo with a turbonet card. But I think that I messed up miserably...

As the shooting from the hip kinda guy I am, I booted up Linux with the nic_install CD and went directly for the tivoflash. No backups due to lack of FAT partition and Partition Magic refusing to repartition my drive. Bad excuse I know...

Anyhow, when I ran the commad /tivoflash/install I got the following (partial) output:

0+9 records in
64+0 records out

Creating boot partition
34+2843 records in
34+2843 records out

Mounting in-active root
/dev/hdc7: Input/output error
mount: you must specify the filesystem
Error: Mount of '/dev/hdc7' on '/mnt/tivo' failed
Error: The exit code was 32
Error: Cannot continue

After that I tried to put the drive back in the TiVo but it would not get any further than to the Welcome screen.

What did I do wrong (except for not making a backup)? Do I need a dos partition to run the tivoflash utility? Should I have unlocked the drive, a 40 GB Fireball lct20? Anything else I could have screwed up?

As it is now I'm in big trouble since the TiVo was full of my wife's 'must see' shows, so I'm kinda in the dog house right now :(

Is there a way to restore the TiVo and keep the shows? If not I might not be allowed to tinker with the TiVo again...

If there is no way to restore the shows, what is the best way to restore the drive to a working state?



Ohhh, if you find the grammar a little bit off it's most likely due to my Swedish accent shining through... bork, bork...

cekowalski
07-31-2003, 07:10 PM
Disclaimer: I'm not an expert by any stretch of the imagination, so take my advice but only after careful review of this forum. Same goes for any advice you follow -- not everything you read is "true" -- although most times bad advice stems from the poster leaving out a little detail, like "this only works on Series 1 Combo units" etc.

Before you do *anything* else, I would try and find a way to do a backup. Yes, you're messed up now, but the more you play around, the further away you get from a good image. There are ways to fix things even if you're totally hosed, but unless you happen to fix this image, you'll lose your shows -- so proceed with caution. I wish you the best -- I thought my wife was going to kill me when I lost all our shows on my first attempt.

Your problem probably comes along in the following two areas. First, you can't mount the drive -- probably you are using an Ultra-ATA card or something, but there could be MANY reasons. One thing I just thought of is that you are trying with HDC -- the forums refer often to not installing your Tivo drive as the primary master, so that might be your whole problem. Either put it on the secondary IDE controller, if you have one, or do a search and see if you can find any reason it wouldn't work when set as a slave. Whatever you do, don't let Windows NT/XP/2000 BOOT -- the drive can be in, just make sure your CD always boots first.

Secondly, the Turbonet instructions don't mention kill_initrd, for some reason.

Now, I think it is possible that you need only run the following command with your drive in your PC:

kill_initrd status

I recommend always checking any hack in a non-destructive way, in case it turns out that it only works with old software, for instance. If the above command seems to work, then:

kill_initrd disable

Then try a reboot. I think I did this before my succesful tivoflash, but I don't know of any reason why it wouldn't work after. Worst case, you may have to run tivoflash again. I'm still studying what exactly happens with tivoflash and kill_initrd, one big reason I recommend a backup.

Perhaps someone else will come along and clear these things up for us...

A side not -- I had the same results with my first attempt that you are having. Stuck at the Welcome screen. Unfortunately, I panicked and restored from the backup I had taken before I found this tidbit about kill_initrd hidden in the forums. Oddly, I could not find a single FAQ that teaches you how to install Turbonet and/or get a BASH prompt on a 3.1 combo unit, which didn't include 25xtream or one of the other images that I really didn't want to put on (since they involve disconnecting the phone line, which I didn't want to do).

I wound up using 9th Tee's instructions, plus running into the kill_initrd command. My Tivo is now running TCS, TivoWeb, and Elseed -- and I can telnet into it.

One note -- restoring from a backup will remove your shows, unless you happen to copy the whole HD (which is quite time-consuming).

Insofar as your drive mounting issue, it sounds an awful lot like you may have installed your drive on an IDE channel that your Linux boot disk doesn't recognize. If that's the case, let me save you some trouble -- I could only get things working on the builtin controller in my machine. My Maxtor/Promise Ultra-ATA, even with the proper Linux boot settings (e.g. IDE2=0xblah, 0xblah), I couldn't mount the drive.

If you can't mount the tivo drive, the tivoflash command definitely won't work. I would focus on getting that far, first.