PDA

View Full Version : Errors being posted in tverr log



tivomaster
08-30-2003, 12:22 PM
I am having the below error posted over and over again in my tverr log...

Aug 30 15:36:15 (none) Scheduler[174]: Scheduled recording 340956 expires before it starts
Aug 30 15:37:24 (none) last message repeated 7 times
Aug 30 15:38:29 (none) last message repeated 8 times
Aug 30 15:39:34 (none) last message repeated 8 times
...

I figure that one of the scheduled suggestions or the todo list is muged but how do I figure out which one?

Or is this a "normal" abnormal error message?

tivomaster
08-30-2003, 08:24 PM
It appears that this is being caused by an aborted attempt to upload a .ty file using mfs_ftp ...

This record 340956 shows up in /mfs/Recording/Active when I browse with tivoweb...


Question is, How do I nuke this entry?

tivomaster
08-31-2003, 08:54 AM
Originally posted by tivomaster
It appears that this is being caused by an aborted attempt to upload a .ty file using mfs_ftp ...

This record 340956 shows up in /mfs/Recording/Active when I browse with tivoweb...


Question is, How do I nuke this entry?

Figured out the problem. It seemed that when the mfs_ftp upload aborted, the recording expire time was not posted correctly. It was posted with an expire date that was munged. What I did to fix it was to undelete the problem recording with tivoweb, then go in with Tivo NowShowing and change the expire to "keep until I delete", then go in with Tivo and delete it. That fixed the weird date. I am going to post this to the mfs_ftp tread in case this happens to someone else.

Fletch319
07-25-2004, 10:20 PM
I had the same problem. Your fix worked great! Thanks for posting your findings!!!

AVD
07-25-2004, 10:39 PM
Jul 25 13:58:42 (none) FsRegion[133]: Free space too badly fragmented
Jul 25 20:49:07 (none) FsRegion[133]: Free space too badly fragmented
Jul 25 21:15:41 (none) FsRegion[133]: Free space too badly fragmented



hmmm.... I get this....

mrbillpsu00
10-08-2004, 10:02 AM
I'm having a similiar issue, but MFS_FTP is not running.

Can this be caused by anything else?

steve457
11-08-2004, 11:38 PM
I'm seeing the same problem, and first thought it was because of mfs_ftp. I then noticed that when viewing shows that were recorded normally on my tivo, that they had the expire date set back in 2001. So now I'm thinking it may be related to something else, I'm just not sure what yet.

This is on a HDVR2 running 4.0.1b-02-2-240, killhdninitrd, hmo superpatch.

I started noticing the problem when I transfered my season passes using tivowebplus 1.0. I'm thinking the script that did the transfer messed up something. I'm going to try and rebuild the system and see if I can isolate the issue.

-steve

chedlin
11-30-2004, 12:29 AM
I seem to be getting this on all my mfs_ftp inserts, saved and deleted. It was easy enough to fix the saved ones, but this repair is tedious.

This also looks like a good place to start programming, so if noone beats me to it I may try to write a utility to find recordings with invalid experation dates and fix it. Unfotunately it won't be till this weekend, so I am sure someone will do this first.

Charlie

badgerbalm
12-01-2004, 09:57 PM
I seem to be getting this on all my mfs_ftp inserts, saved and deleted. It was easy enough to fix the saved ones, but this repair is tedious.

This also looks like a good place to start programming, so if noone beats me to it I may try to write a utility to find recordings with invalid experation dates and fix it. Unfotunately it won't be till this weekend, so I am sure someone will do this first.

Charlie

I would be very interested in the utility seeing how I'm getting the same error. I just tried to delete the shows that mfs_ftp'd back to my Tivo once I swapped out the drive. I'll have to see if that fixes my problem, otherwise I'm will to try out your util.

chedlin
12-02-2004, 10:15 AM
I would be very interested in the utility seeing how I'm getting the same error. I just tried to delete the shows that mfs_ftp'd back to my Tivo once I swapped out the drive. I'll have to see if that fixes my problem, otherwise I'm will to try out your util.

Deleting won't work, manually setting the expiration date ("Keep unil") will (from now playing with the remote or TiVoWeb). Still planning on it this weekend, but my life is upside down right now, so it may not work out. Chances are decent though.

CHarlie

chedlin
12-05-2004, 12:22 AM
I have a script that will reset the expiration date on the invalid shows. There is a bug in mfs_ftp that causes it to get set to an invalid value. I have seen other posts referencing it, so it should be fixed in the next release.

Here is a script that you can run after inserts to clean things up.

Just copy it anywhere into the tivo (I used /var/hack), type chmod +x fix_expdate.tcl, then run it. It will report the fsids it fixes on std_out.

chedlin
12-07-2004, 01:08 AM
If anyone finds that utility usefull I would love to hear about it. It was my first attempt at programming with tivosh.

It worked perfectly on my two TiVos.

Charlie

hayreass
12-07-2004, 03:24 AM
If anyone finds that utility usefull I would love to hear about it. It was my first attempt at programming with tivosh.

It worked perfectly on my two TiVos.

Charlie
Works outstanding for me on a T60 @ 3.1.0c2
My tverr log was over 28,000 lines long due to these errors

Thanks

LJay
12-30-2004, 06:33 AM
If anyone finds that utility usefull I would love to hear about it. It was my first attempt at programming with tivosh.

Modified it a little to fix a problem on my TiVo where TiVoWeb had set an expiration date less than the StopDate.

Thanks!

mikey
01-01-2005, 10:03 PM
If anyone finds that utility usefull I would love to hear about it. It was my first attempt at programming with tivosh.

It worked perfectly on my two TiVos.

Charlie
Thanks, My logs aren't growing uncontrolable anymore.
Mikey

taw123
02-09-2005, 08:04 PM
Got a bit of a problem.....

Do I ned to set some var to use this script?

/var/hack# bash fix_expdate.tcl
fix_expdate.tcl: global: command not found
: command not found
fix_expdate.tcl: global: command not found
fix_expdate.tcl: ForeachMfsFile: command not found
fix_expdate.tcl: RetryTransaction: command not found
fix_expdate.tcl: line 20: syntax error: unexpected end of file


I have the same problem of a Scheduled recording expires before starting. I can't undelete it with tivoweb plus but can browse to it in /mfs/Recording/Active.

First I would like to know if ALL MFS_FTP copies I make will have this problem, how to fix (no luck on the script), can one undelete items that are in the active directory but the tivowebplus module doesn't see, and if MFS-FTP has been fixed

Thanks for the help, really want to finish off this tivo and clone it to the others in house (DTivo, 4.01b, running TWP 1.1 pre 2).

mikey
02-09-2005, 08:54 PM
assuming it is in /var/hack
try

/var/hack/./fix_expdate.tcl