PDA

View Full Version : UTV HD upgraded.... but problems



kgibbons
09-01-2003, 12:48 AM
Hello All,

Many thanks to a kind soul on this board for hooking me up with a RAR archive of the v3.5 image :) PM me if you need one, I would be more than happy to share.

So anyway.... I copied the image to my WD 120gb drive, but for whatever reason when I fire the system back up with the new drive in place, it's hell bent on trying to connect to WebTV. Let me lay out the steps I did so far:

1. Zero'd out the drive using WD diagnostics. I did this because I had the drive in use for a short time on a Linux machine, so it had RedHat 9 setup... and it can be a bitch to wipe off the boot sector, so I usually zero them out when I want to go with Windows.

2. Now I have a sparkling clean WD 120gb drive to use. So I ran FDISK on the drive, and setup one large 120gb FAT32 partition -- so Windows would at least be able to see the drive.

3. I launched Windows with the drive slaved on the system, and formatted the drive. Not even sure this was necessary, but I did it anyway.

4. Now I launched WinHex and followed the readme instructions I got with my v3.5 image right down to the last letter (including a copy of the readme below). However, I was wondering since I setup a FAT32 partition and formatted the drive if I would have some problems after I overlaid the image?

5. Now I overlaid the image as per the readme, and popped the drive into my UTV.

6. I made sure I had no HU card in the system, and then I fired it up for the first time. It came on like a champ, but immediately went to "Connecting to WebTV" screen.

It seems it's really set on trying to connect to WebTv to see if "upgrades are available".

So right now I'm at a loss as to how to proceed, and also questioning the whole partitioning/formatting procedure I used. Once I get this bugger working, I'm going to modify that readme a little bit and re-post just for clarification sake.

Any help from some experienced UTV guys would be greatly appreciated!


Here's a copy of the readme I used:

Thanks to Huculito on dsschat for the post.

UTV HDD SWAP, Via Computer or How To Save Your rev 3.5 for Future Use

This is not my work, or my Findings.. i Was helped and Allowed to post this info for all of you that need this help, I can help you with your questions.. since i already did this and it worked great

NOTE.. YOU NEED TO HAVE COMPUTER HARDWARE SKILL'S TO TRY THIS..OR ELSE YOU COULD DAMAGE YOUR COMPUTER OR UTV

YOU NEED A WORKING (NOT EVALUATION) COPY OF WINHEX

While the utv is running, unplug the ide cable, (leave power applied)boot your computer hit pause before it detects ide drives plug ide cable from computer into drive and hit enter the drive should now be detected.
run winhex, from tools select physical disk(start center on some versions,then select the physical disk that is your utv), from position goto offset 13480600 look at 13480624-7 in the display it should read FSNo
right click the first byte (13480600)select begining of block now from postition tab goto offset 154805ff right click, select end of block. from edit tab select copy all into new file and name it on your local drive.
(if FSNo is at 15480624 instead of 13480624 then select 15480600-174805ff and do the same)

Now that you have the file you can disconnect the drive and hook up your new drive. on the new drive select offset 0 as begining of block and 178c2fff as end of block. From edit tab select fill file,select first option and type in 00 for hex value (if the drive is already zeros you can skip this step)
after it zeros that chunk goto tools then disk tools then clone disk
on source file select read sectors from image file and select the file you saved from before. select your destination drive and start sector will be 631811 (this is lba 13480600 or sector 09a403 in hex...which is sector 631811 in decimal)(make sure you select copy entire source) and click ok it will write the sectors and you and the drive should be showing the data starting
at 13480600 now disconnect the drive install it in the utv plugin the power cord utv should now come up to the welcome to utv screen.

note this new hdd will no longer work on the computer unless you do the same procedure and erase all the content (i think i havent tried yet)

Hopes this helps many as it did helped me..
thanks to the finder of this info
DONT TRY THIS IF YOU ARE AFRAID OF RUINING YOUR COMPUTER OR UTV
IT WORKED GREAT FOR ME AND DID IT TWICE

GOOD LUCK

kgibbons
09-01-2003, 01:36 AM
One last bit of info in diagnosing this problem. The drive I'm using is a WD 72R WD1200JB

I came across another post from someone having a similar situation as mine, and he discovered the drive he was attempting to use wasn't a "locking" drive, and ended up having to get a different drive to make his upgrade work. I don't know if I'm going to be in the same boat as this or not with this particular drive -- but I sure hope not :)

kgibbons
09-01-2003, 04:11 PM
While I'm still waiting for a response from any knowledgable UTV guys, I figured I would post an update :)

Ok.. I think I've narrowed my problem down to the method I'm using to apply the UTV 3.5 image. The reason I believe it's this, is because I now tried a second 120gb drive I had in another PC. Here are the EXACT steps I used with this drive:

1. Deleted the NTFS partitions the drive had -- it was being used on an XP system.
2. Ran FDISK from my Win98 startup disk, and gave the drive one full-size FAT32 partition.
3. Slaved the drive to my windows machine, and booted into windows.
4. Formatted the drive while in windows.
5. Verified that the drive now read 120gb, and was accessible through windows.
5. Launched WinHex - and on the "Start Center" page, I chose "Open Disk", and selected the 120gb drive.
6. While in WinHex, I chose Edit>Define Block -- and left the start of block set to 0, and entered 178c2fff for the end of block.
7. Next I chose Edit>Fill Block -- and left the first radio button checked for "00" to fill this block up with zero's.
8. After this block zero'd out, I then went to Tools>Disk Tools>Clone Disk
9. While in the clone disk selection, I chose to read sectors from image file, and it then opened up the search box so I could select my UTV3.5 image file -- which I did.
10. I then chose the 120gb as my destination drive, and made sure the "copy entire source" box was checked. And lastly I chose a start sector of 631811
11. I then clicked "OK", and the image was written to the drive in about 30 seconds, and I was then back at the main hex screen looking at the data at location 13480600.
12. Then I closed out of WinHex, and powered down the PC... then swapped the drive over to my UTV.

And once again, with BOTH the maxtor and the western digital drive, I'm immediately getting the "calling webtv" screen. The drives were both set to MASTER when I put them in my UTV, so that's no an issue here either.

If you look at the way I applied the image, it's slightly different then the readme above. I chose to use "define block" rather than manually scroll down the hex screen and choose a start and end block. This was only because I literally couldn't locate 178c2fff to set it as the end point. But I figured using "define block" would do the same thing -- maybe I figured wrong?

Or maybe I'm using the wrong type of partition? The whole drive preparation thing is a big question mark, since it's not really talked about in any of the writeups I've read on upgrading.

This thing is really driving me bonkers.. so any help would be VERY much appreciated! :D

Kazak
09-01-2003, 05:27 PM
Hi,
Try it again but use a zeroed drive. No partition and no format.
Windows will not see it but the bios and Winhex will.

kazak

kgibbons
09-01-2003, 05:32 PM
Originally posted by Kazak
Hi,
Try it again but use a zeroed drive. No partition and no format.
Windows will not see it but the bios and Winhex will.

kazak

Going to try this in a minute... but how would WinHex be able to see it if it's not even available in Windows?

kgibbons
09-01-2003, 10:34 PM
Well, the zero'd out drive did the trick... I'm up and running once again with v3.5 and a bigger HD :)

I wasn't aware that you could choose "physical drives" in WinHex, rather than just drive letters. That's why I figured you needed a pre-existing partition on the drive.... but this is NOT the case.

For anyone about to do a HD upgrade using an image file, make sure you do this on a totally blank drive with no partitions.

Many thanks for the head's up on that one Kazak.

Kazak
09-01-2003, 10:55 PM
Just glad you got it going. :)

kazak