PDA

View Full Version : HD upgrade problem



xtwister
10-17-2003, 09:04 PM
I was trying to upgrade the hd drive following the instructions in the other threads and it still will not recognize the OS.
I tried zeroing the drive / formatting then zeroing again.

I used the OS3.5 I also read my old OS which was 3.5 also. I dumped that file and tried it. Still nothing.

I read the new hard drive and it has what it should on it.

I think its the sector. The 631811 which is in the help files.
I read my old drive and the file started at 15480600

What would the sector be for this value?

I did read somewhere that the HD flags the startpoint. But I have the feeling its in the bios?!

Can anyone help? I'd like to get it working with the new drive.

I havent tried to clone the drive from hd to hd. would that work in winhex?

David Bought
10-17-2003, 10:01 PM
Sectors are 512 (0x200) bytes, therefore offset 0x15480600 is sector 0xaa403 (697347).

There are two different starting sectors that the ROM checks to find a CE image. Obviously only one can be active at a time.

xtwister
10-17-2003, 10:46 PM
Thanks David for the reply. I tried that sector and it didnt work so I applied the image on the drive and tested after each one and the final time vola it worked. Nothing was done different than the other times. Well now I have it put back together and can reprogram the shows!