PDA

View Full Version : New 2.5.2 install not working 100%... Need help.



Toaster
10-23-2003, 03:01 PM
I wasn't sure where this was most appropriate, but it seemed a bit 'newbie'ish, so I figured here is as good a place as any.

I recently bought a second Dtivo, its a DSR6000, and my 1st (original) setup is a GXCEBOT. FWIW: When I did my first G-bot I basically followed the steps (not in order really) found HERE (http://www.angelfire.com/darkside/wanker/DTiVoBasicsAndBeyond.htm) (more on this later)

OK- So I pulled the 40gb quantum from the DSR6000, to replace it with a 120gb WD. I first connected it to a PC and booted from a DSR6000 2.5xtreme CDR- At the end of the process I noticed a signature "-Surgeon-" so I guess it was HIS initial compiled CDR (if that matters?), then used files from the Superzap's upgrade (3.1/2.5.2) .iso, which has xPlusz included... So after I installed 2.5, I put the drive back in the Dtivo, let it reboot, then load and get to TV (yippee), I let it run for a while while I sent the [/b]upgrd252.tar[/b] and stuff via the serial port and bash prompt to the /var/hack dir. (*note: I didn't manually install ANY other hacks to this point, like I had done on the Gbot. The only thing I did this time was touch /etc/fixsub.tcl and forced the daily call to get the 5:lifetime sub activated). So once the upgrd252.tar, upgrd252.tcl, upgrd252.sh were all in place, I had to cp then to lowercase names first, because they were all uppercase and the script didn't like that- and I couldn't remember which command was RENAME :confused: so I cp then FROM UPPERCASENAMES to lowercasenames, then I chmod 777 the upgrd252.tcl script, and at the bash prompt entered ./upgrd252.tcl, the script fired up- took off and ask me if I was sure I wanted to continue, blah blah blah- and a few minutes later the Dtivo rebooted and it was running SZ's 2.5.2 (yippee again).

Now at this point, I started reading the readme, where the xPlusz commands and short descriptions are located- and started executing commands to finish hacking my 2nd Dtivo- I got to tell you that at this point I'm pretty jazzed and excited because of the first one- following the directions linked above, I manually installed a bunch of stuff by editing TCL files, .ini files, using joe and whatnot- and from what I understood- this was going to do all the same things, and be painless! :D

So I went down the list from #0 to #65, and issued commands, a few from the remote in the dialing prefix section, a few from the Bash prompt XP "###,##" because it was faster. Here's what I did:
#2 run sc.tcl for showcases
#3,43200 run NOPPV every 12 hours
#5 toggle 30sec skip
#16,48 to run TivoTitle at :48 past the hour
#20,1 to enable addlocal's
#21,1 to enable NOPHONE
#25,1 to enable TivoTitle at previous clock times
#28,1 to enable CRON, but it said it was already enabled
#47,1 to enable NOSCRAMBLE
#50,1 to enable daylight savings times
#60,5 to add Dallas local channels.

Now you're 100% upto speed- here's where my problems start. I tried to force a daily call=failed no line detected. Tried to issue #21,1 again, said it was already on, force the call again, failed again. did the touch fixsub.tcl and reboot, force daily call=failed, let it sit over night, force daily call this morning=failed. Still says 5: lifetime sub, but daily called=failed. :(

The showcase stuff came in last night (tivomagazine, and the yellow star junk), but still no local channels. The noppv worked because when I set a PPV to record, it doesnt ask me to set "purchase" info, just records like channel 501 or whatever... I'm not sure about the tivotitle yet, or noscramble. Oh and the 30sec skip didn't work either, press the "skip" button and it goes to the end of the recording/buffer.

So my problems right now that I can see are: the NOPHONE not working (pretty important), No 30 sec skip automatically, No local's after nearly 24 hours, I'm guessing no tivotitle, but I'm not 100% on that, and I can't tell if the noscramble is working or not.

Did I do something wrong? did I miss something or do I misunderstand the concept of xPlusz?

On my Gbot, I had to use midupdate.tcl to get locals- and they came in and stayed in- I thought the #60 addlocals was the same thing?

So what I am doing wrong? Guidance/help or advice- any would be appreciated :)

Thanks
-Toaster

captain_video
10-23-2003, 03:29 PM
Fixsub doesn't work with 2.5.2 so running it won't do anything. If your status indicates a 5 for lifetime status then the nophone hack is working. Don't worry that it shows the last call as having failed. It's the account status that's the important factor to look for. Since you allowed your DTivo to acquire the guide data between installing 2.5Xtreme and Superzap's 2.5.2 upgrade, you're going to have to do a Clear Program Data & To Do List for your locals to come in. I wrote a tutorial on going through his entire procedure so that you could avoid exactly what you're going through. You'll find it in the How Tos Only sticky thread in the DirecTivo Hacking Forum.

David Bought
10-23-2003, 04:40 PM
Originally posted by Toaster
I wasn't sure where this was most appropriate, but it seemed a bit 'newbie'ish, so I figured here is as good a place as any.

1) The unix command to rename is "mv" (move)

2) Lay off the caffeine

Toaster
10-24-2003, 02:05 AM
Captain Video,

Thanks for your reply- I did the clear data & todo list earlier, let the Dtivo sit and re-populate its guides and databases... however I'm still at the same square- no locals, the force phone call will not complete and the 30 sec skip is not on by default.

My other Dtivo (1st one) has my Local's, 30 sec skip by default, and the force call completes...?

When I issue the #60,5 command to add Dallas local's I get a 998 error on screen....

I'M STILL CONFUSED :confused:

captain_video
10-24-2003, 08:27 AM
The one thing I found most frustrating when trying to upgrade my DTivo and get locals was trying to perform all of the various xPlusz commands, run midupdate.tcl, and every other "fix" I could find but nothing seemed to work. Finally, I started over from scratch and discovered the method that worked for me every time for getting locals. The tutorial I spoke of can be found here. (http://dealdatabase.com/forum/showthread.php?s=&postid=112382&highlight=Heres+a+detailed+tutorial#post112382) You might want to consider starting over instead of trying to patch an existing installation that doesn't want to cooperate. I install the 2.5.2 upgrade from a boot CD (burn the xupgrade.iso to a CD as an image and it will be bootable). and it works for me every time. I have upgraded at least three DTivos using this method and my locals came in the first time on every one of them.

Toaster
10-24-2003, 06:15 PM
Originally posted by captain_video
You might want to consider starting over instead of trying to patch an existing installation that doesn't want to cooperate.

Now is the best time, before it fills up with show's :D

I guess tonight or tomorrow I'll start over again- as now I have discovered the NOPPV is not working anymore :mad:, I'll burn the 252upgrade .iso - I guess the only variable I have is, my original 2.5xtreme by -surgeon- is that a good base?

captain_video
10-24-2003, 08:25 PM
Since Surgeon was the original developer of 2.5Xtreme then I'd say you have the right version. BTW, there aren't any other versions of 2.5Xtreme, just different images for either the Philips/Hughes and Sony models.

Toaster
10-27-2003, 06:16 PM
Captain Video,

For the record, I was unable to ever get 2.5.2 installed and working correctly using this method... It never updated past 2.5, and xplusz never worked.

Steps I followed: pull drive, installed drive a as hdc (secondary master), boot from 2.5xtreme iso, enter twice, then 25xtreme, follow prompts for hdc, tivomad, etc. finished, then ctrl alt del, shutdown, pull drive install drive-a back in dtivo with no sat feed, let it (re)flash proms, power up, rebuild database, when it got to acquire sat/guide info (with colored balls on bottom), pull power plug, remove drive-a, replace into pc (as hdc), boot with 2.5.2 & 3.1 upgrade .iso, get to prompt type upgrd252.sh, follow prompts, then umount drive as instructed, ctrl alt del, replace drive-a back in dtivo, power up with sat feed this time, got the service interupted msg, went to phone settings to activate xplusz, change call waiting prefix, nothing happens. check system info, says 2.5.001 (or whatever, NOT 2.5.2.xxx)

Tried again, without doing the umount command at the end, same result. tried a third time with a B drive this time aswell (2 drives), same result. I ended up using a backup from my existing Dtivo, got the error #51 msg, and in the process of clearing data and todo list now.

Thanks for your help, but thought you might want to know- for whatever reason, I could not get it working after 3 attempts. And btw, I downloaded new .iso's from tivostuff.com before I started just to make sure I had newest versions and proper images.

-Toaster