PDA

View Full Version : came home to a dead tivo



3aeblo
10-30-2003, 03:26 AM
Hi,

I got a sony sat-t60 recently. I installed turbonet, ran 25xtreme, upgraded to 3.1, installed the fixsub, tivoweb, logsnull, and noppv hacks. I did the hardware prom protection (by desoldering pin 31 and connecting it to pin 32). Everything worked beutifully until I left it plugged in (on standby) for the first time (with a bunch of recordings scheduled). I came home from work, pressed the power button and nothing happened. I tried to ping it from my pc, and it didn't respond. I then proceeded to unplug the tivo and plug it back in. The screen flashed white for about a quarter of a second, then went blank, and nothing happened from there. If I do this repeatedly, sometimes I get the "Welcome Powering up" message for a few seconds, then the screen goes blank. I never see the "Almost there" message and I cant ping the tivo. The power led is on, the fan is working, the harddrives are spinning, but it doesn't boot. I tried plugging in another harddrive from a friends dtivo (with 2.5), and nothing changed. I tried cleaning the ribbon cable between the power supply and the motherboard, to no avail. Could it have been a bios flash from tivo? The hardware prom protection should have prevented that, right? Has anyone expirienced anything similair? Any thoughts would be greatly appreciated.

Thanks.

captain_video
10-30-2003, 09:16 AM
Check all of your cable connections, especially the IDE cable for the hard drive(s). It sounds like you may have an intermittent connection on the IDE bus that's preventing it from booting. Since the drives are spinning up and the fan is running it sounds like the power supply is OK. The ribbon cable may also be suspect and, even though you have already checked it, the DTivo has a tendency of being uncooperative if the cable is not seated 100% correctly. The EEPROM should not have been flashed since there haven't been any software updates newer than 2.5 that would have made any changes to the EEPROM.

3aeblo
10-30-2003, 04:02 PM
Hi, Thanks for your reply. I tried swapping the IDE ribbon cable, and the ribbon cable between the power supply and motherboard from another tivo. No luck.

genericuser
10-30-2003, 08:47 PM
The fact that it wont even say powering up implies a power supply problem. Test the hard drives with a non-destructive test and see what happens there.

3aeblo
10-31-2003, 03:23 AM
The harddrives boot in another tivo. So it's doubtful that they would be the problem. I cleaned the ribbon cable between the power supply and motherboard with DeoxIT, but nothing changed. I swapped in the power supply from another tivo, and got the same result. I also probed the connection with a meter, and everything seems fine. Anyone know where to buy a T-60 Motheboard? :( Or, anywhere I can send the tivo to have it repaired?

P.S. It does say "Powering Up" about 50% of the time, but then it just goes to a blank black screen and nothing happens.

Thanks for the replies.

captain_video
10-31-2003, 10:43 AM
If you've got a bad MB then your best bet would be to see if you can find a DTivo that someone is selling for parts that's got a working MB. A replacement MB would cost for more than you paid for your entire DTivo. I don't think there are too many places that will even attempt to repair a bad MB since everything is surface mounted and is a complete pain to work on without the proper equipment.

Have you tried the power supply from the suspect DTivo in another unit to rule it out? I've encountered flaky power supplies that didn't work in one DTivo but worked fine when installed in another unit. Chances are it had to do with the ribbon cable.

I would go back and check your cables again with a fine tooth comb, especially the power connectors between the power supply and the hard drives. The pins have a habit of getting pushed out the back of the connector and it's possible you have one that's making intermittent or no contact.