PDA

View Full Version : DTivo stuck



thecoral
11-14-2003, 12:41 AM
I posted this message in the wrong forum previously, so I'm posting it here. My DTivo S1 was working without problems with my wireless connection (TivoWeb, TCS, etc). I edited with TextPad the rc.sysnit file so it will call another file in my /var/hack directory that loads the different hacks. I uploaded this edited rc.sysinit and since then agter rebooting, the systems hangs in the screen "Welcome. Please wait..."

I received a reply in the other forum suggesting to use a serial connection ot move the file to my PC. I moved it to my PC.

I used a Linux boot diskette and mounted partition 4. Then, using vi, I deleted the lines that called the other file. I put the drive back in my DTivo and again, I couldn't pass the first screen.

I attached the HD again to my PC and I did a restore of the original copy of rc.sysinit that I had saved before installing some hacks as rc.sysinit.original in the same directory.

Again, after puting the HD back in my DTivo, I can't go further ahead than the first screen.

I would hate to reformat the HD disk and start all over again. (I've spent weeks trying to put it together following threads and with the help of some members of Tivo forums).

Any ideas of what else can be done?

The software in my DTivo is 3.1....

Thank you.

BubbleLamp
11-14-2003, 01:03 AM
My guess is you didn't save the file the first time in *nix format. Rediting alone wouldn't have solved the problem if that was it.

Assuming your backup file was alright, did you remember to chmod +x the file?

thecoral
11-14-2003, 09:11 AM
I'm pretty sure when I saved the file I did a Save As and I checked the format was Unix.

I didn't perform a chmod +x on the backup. I thought since originally I did a cp rc.sysinit rc.sysinit.original, all the attributes were copied as well. I will try that once I get home.

I have one question. At the point the DTivo is stopped (Welcome screen), did it read any hard disk file or is it stopped while trying to read the rc.sysinit?

captain_video
11-14-2003, 10:09 AM
Anytime you transfer a file to your PC and then back to your Tivo you need to reset the permissions. You Tivo is not booting because the rc.sysinit file is not executable. Once you've done a chmod +x to it you should be fine.

SR712
11-14-2003, 05:56 PM
Be sure you reset the jumpers on the hard drive when you put it back into the TiVo.

thecoral
11-14-2003, 07:02 PM
I changed the permissions and it's working again. Thank you!!!

I also had the jumpers as a slave after I restored my backup. That's probably why the backup file that was on the DTivo didn't work.

Thank you again.

Now, back to work...