PDA

View Full Version : Error #51



bisk
11-19-2003, 10:40 AM
I'm running a S1 Highes DTiVo with KRavENs 3.1. When I try to go to Now Playing, I get an error about a hardware problem and that I need to reboot the TiVo, I do that and it never goes away. I installed xPlusz and ran #21,1 and that didn't fix it either. What can I do to get rid of this error?!

Thanks

captain_video
11-19-2003, 10:46 AM
This error occurs when trying to use an OS image from another Tivo. The Tivo service number recorded in the software doesn't match the encoded number on the mainbord, resulting in the error #51 message. This is easily remedied by performing a Clear & Delete Everything from the System Reset menu under Messages & Setup in Tivo Central. If you have a bash prompt and a serial or ethernet connection to your Tivo you can upload a script called 51killer.tcl that's available from the tivostuff website. Simply transfer it to your Tivo, make it executable (chmod +x 51killer.tcl) and execute it from bash (./51killer.tcl) Either method will clear out the error #51 message and allow normal operation.

bisk
11-19-2003, 11:23 AM
Cool...thanks. I'm trying it now, and I'll see if it worked when I get back from work.

sangleweb
11-21-2003, 11:46 AM
Before I do this, just want to confirm. I have tivo that is hack but I want to move the hd to another system, if I do a clear and delete on the new system, does it remove all my hacks or should I run the script? Thanks.

mrblack51
11-21-2003, 12:04 PM
Originally posted by sangleweb
Before I do this, just want to confirm. I have tivo that is hack but I want to move the hd to another system, if I do a clear and delete on the new system, does it remove all my hacks or should I run the script? Thanks.

clear and delete everything doesnt touch the filesystem, only the mfs database. however, since clear and delete everything will take a while, i would recommend using the script since you have bash. it will takse about 10 seconds plust the time to reboot, rather than over an hour