PDA

View Full Version : Tivo Troubles (involves fire & smoke)



LiquidPlasma
11-22-2003, 06:03 PM
I decided to try to add a bigger hard drive to my TIVO today. I got everything set up, hard drives backed up, new drive loaded with all of the scripts and goodies. and as i'm plugging the TIVO back in to test it out the palm of my hand grased the unshielded power supply. It was not pretty there was smoke and a little fire. The motherboard looks undamaged, but the power supply has some nasty burn marks. I've searched high and low, checked out 9tee and all of the other usual TIVO places. buy can not find a replacement power supply. Best Buy, the place where I bought it won't help me, and Tivo's tech support are a bunch of ^#$%#@. Apparently after opening the TIVO unit they can no longer help me with anything. They wont even sell me a new power supply

Does anyone know where I can get a replacement Series 2 40 hour TIVO power supply? Or would someone be willing to sell me theirs?

I'm 99% sure it's the power supply that's damaged, i can post pics if it will help.

The ones i've seen online are square shaped, and don't look like they would fit in my TIVO without removing the fan. I need the L shaped power supply.

Sleeper
11-22-2003, 08:10 PM
GREEK is the guy to talk to. PM him if he doesn't reply to this thread.

vu2vu
11-23-2003, 06:21 AM
Double chedked, I guess they don't sell after all.

GREEK
11-23-2003, 08:08 PM
not sure if the weakness ones are for series2 units. what kind of tivo is this, SA or Dtivo, and what model? I also responded to your pm......