PDA

View Full Version : Can't figure out DirecTivoMad



hayreass
01-16-2004, 09:46 PM
Ok, here's my story...
Bought and fixed a tivo (gxcebot) a couple of years ago, thanks to all the stuff I learned from reading, reading, reading here and other places.
Recently upgraded my software to 3.1 even (just for the sort feature in now playing)
Recently, I have had the feeling that the drives were dying (noise, slow operation, artifacting), so I bought a couple of Hitachi 123.5 gig drives.
I copied over all the stuff from the western digital drives today (80 gig "A" and 120 gig "B")
Now I can't figure out how to expand my "A" drive to fill the remaining space...
Or the "B" drive either for that matter, but I don't really care about 3.5 gigs. 43 gigs lost on the "A" I do care about though.
I did a lot of reading and investigation before I started this project, and thought I had it all worked out, but I just cant make it happen..
Here's what I have done....

using mfs boot floppy, I did a dd mirror of both drives... that works like a champ... (dd if=/devhdc of=/devhda for the "a" and dd if=/devhdc of=/devhdb for the "B)
First time around I used this command next to try and expand the "A" drive mfsadd -x with every combination of /dev/hda /dev/hdxxxx I could think of (b,c,and d)
I just kept getting errors, and it did nothing.
Put drive back in tivo, and it still worked though..
So next I downloaded and burned a copy of directivo mad (i think)
Tried running it with the command
maddtb4/setupcd.sh
Went through the procedure, syaing yes to a second drive, and no it's not connected....
Nothing.... tivo reboot loop
tried this 2x (re-mirroring the drive between tries)
Next I told it no to the B drive, still doesn't work...
I can live without it, but it just seems so wasteful having those extra 40 gigs sitting in there doing nothing

I am at my wits end here... if someone can help, I sure would appreciate it.

Brian

ronnythunder
01-16-2004, 10:12 PM
first, lose the tivomad stuff (no offense if you're still watching, trev!). it's way outdated.

next, it may be that you can't use the additional space. you can only have a certain number of mfs partition "pairs", and some two drive configs end up using the limit.

you said you had "errors"; what were the errors exactly (and i mean exact; redo the steps up to the mfsadd if necessary)? another idea you can try is using pdisk to list your current partitions on both drives; post that here and we can take a look.

ronny

hayreass
01-16-2004, 10:20 PM
I guess I'll have to read up on the pdisk thing... dunno what it is
Logging off now to try again on a 3rd hitachi drive...
I'll take a photo of the screen so we can see EXACTLY what it says.
Thanks for the response by the way....

hayreass
01-16-2004, 11:44 PM
Here is an attachment of the screen when I tried the mfsadd again...