PDA

View Full Version : SA2 stuck on welcome screen after cold boot



Randyr
02-06-2004, 02:02 PM
I added a second drive to a Tivo SA2 last fall. I used it for a few months, but then got Directv tivo, so the SA2 sat for about a month (unused and unplugged).

This week, I wanted to sell the unit to someone (without the second drive), so I removed the second drive and used mfsrestore to restore my backup image to the original tivo drive (I had tested my backup image when I originally made it).

Everything went well, although it had to go through a new firmware download from tivo (wait for an hour). Even after that, with multiple restarts, everything was fine.

I gave the tivo to the buyer, and he said it got stuck on the welcome screen. I took it back, and sure enough, it did. I popped the cover, and the fan and the hard drive were spinning. Cables all appeared to be seated.

I restored the backup image to the tivo drive, again, and everything seemed fine. I went through the hour-long firmware download, again. Tried a bunch of restarts and everything was good.

I decided to see if the problem was relating to a "cold boot"... unplugging the tivo unit and leaving it unplugged overnight. I tried it, and it stuck on the welcome screen, again!!!

Any suggestions?

I haven't tried replacing the hard drive or the cable, but I don't understand why it would work while doing "restarts" but not "cold boots".

Thanks!

KarateMom
04-30-2006, 12:11 AM
Hi,

I purchased a TIVO2 from eBay and got it today. However, it's stuck on the welcome screen. I called TIVO tech. support but they said I have to turn it in to get a new machine for $49+shipping. I rather not do this since the original seller upgraded the hard disk to 923 hours.

Any tips on getting it to work ?

Thanks.

PlainBill
04-30-2006, 12:21 AM
If it was listed as working, contact the seller, tell him it isn't working, and you would like a refund. If you paid via paypal be prepared to contest the charges.

From a hardware approach, if you capture the serial console output (http://www.dealdatabase.com/forum/showthread.php?p=234467#post234467) we can probably figure out what is going wrong and give hints on fixing it.

PlainBill

Narf54321
04-30-2006, 12:27 AM
Sounds like you have two hard drives. If it is stuck on "Welcome... Powering Up" then something with the drives probably worked its way loose during shipping (assuming the thing actually worked at all). Any repair or fix to this thing is going to require opening it up and monkeying with the innards. It could be something as simple as a Master jumper pin falling out, an IDE cable working free, or as complex as the power supply not providing enough current for two drives.

Since you just got the unit, you don't need to worry about salvaging any recordings. In fact, it may be worthwhile to find a minimal mfsbackup image for your unit and set it up from scratch yourself. If you do this, I recommend setting up your Tivo with one drive, and once that works add and expand the second drive.

Start with the stickies and especially getting a serial console cable working. Being able to see exactly what hangs the Tivo goes a long, long way to fixing the problem.

KarateMom
04-30-2006, 12:41 AM
Hi PlainBill & Narf54321,

I am a Windows software programmer and running Windows 2000. I read the instructions on how to setup for serial cable and it seems to me that the instructions are for a Unix system of some kind. Can you please sed some light what I should do next. I am just not very hardware savvy.

Thanks !:(

PlainBill
04-30-2006, 03:28 PM
OK, I'll write this for a Windows 2000 user. I assume you are capable of simple hardware changes like hooking up a hard drive. If not, I can't help you.

First, check Narf's suggestions on cabling.

Download PTVupgrade's LBA-48 boot cd ISO and burn the image to a cd.

Remove the primary hard drive from the TiVo and hook it up to the secondary adapter in your computer. IMPORTANT !!! Disconnect the Windows 2000 drive; you do NOT want it booting to Windows 2000 with a TiVo drive attached.

Boot from the PTVupgrade cd. This will boot to a linux distro with the tools you will need. I will assume the TiVO drive is secondary master.

bootpage -p /dev/hdc should show the current boot parameters. It should report something like root=/dev/hda4 or root=/dev/hda7

Now update the boot parameters with bootpage -P "root=/dev/hdax dsscon=true console=2,115200" -C /dev/hdc

Verify it updated with bootpage -p /dev/hdc

Now return the drive to the TiVo, hook up your Windows 2000 drive, hook up the serial cable, start hyperterm using settings of 8,n,1, no flow control, baud rate of 115,200 and boot your TiVo. You should see your the serial console report. ATTACH it to this thread.

PlainBill

KarateMom
05-11-2006, 02:04 AM
Hi, it turned out that one of the hard disk was not hooked up to the power supply. We fixed this and now everything works. Yippeee...Thanks to all for trying to help out.