PDA

View Full Version : Help: Streaming again to PC from TiVoWebPlus 1.0 on DirecTiVo



Fofer
04-01-2004, 02:12 PM
Hello... I am having a hard time getting the streaming "view" link to work again so I can view shows on a PC on my LAN. It used to work fine but for some reason it's not working now. Every time I click a "view" link, Windows Media Player launches, but then I get the error message "A Security Problem has occurred."

I have Windows XP Pro, Windows Media Player and TyShow Beta 0.14 installed. Of course the extensions and mappings are correct.

I am running TiVoWebPlus 1.0 final and "vserver-ppc-s1-exec" on my upgraded Phillips DSR-6000R01. I modified the tivoweb.cfg file so that TyShowLinks = 1, and I also modified my rc.sysinit.author file so that (hopefully) vserver-ppc-s1-exec launches automatically.

I just tried launching vserver-ppc-s1-exec manually via telnet, and get this response: "listen failed"

So I'm wondering if there's something wrong with my vserver-ppc-s1-exec file, if there's a newer version, or if anyone has seen this "security problem" before.

The weirdest part about this is, it used to work, and I haven't made nearly any changes since. I did upgrade to TiVoWebPlus 1.0 final but figured this question was more suited for this forum.

JohnSorTivo
04-01-2004, 02:33 PM
just tried launching vserver-ppc-s1-exec manually via telnet, and get this response: "listen failed"
That probably means you already have vserver running, and therefore can't launch it again. Issue the command:

ps x

And see if you see "vserver" in the list of processes running. It is likely that you will, and thus the reason for the "listen failed" message.

Take note of the "PID" number assigned to your "vserver" process, the 3 digit value in the first column, and manually kill the process:

kill -9 "PID_NUMBER_FOR_VSERVER"

Then relaunch vserver again manually. This time you shouldn't get the "listen error" message, then try connecting again and see if you get the same security error message.

Fofer
04-02-2004, 03:11 AM
Thanks JohnSorTivo, I really appreciate your response. I just tried this out.

Sure enough, vserver-ppc-s1-exec was already running (due to my startup script.) So I manually quit it, and then manually relaunched it. This time it didn't say "listen failed," instead it said "listening on port 8074"

Anyway, when I went back to the NP list in TiVoWeb, and clicked "view," WMP came back with "a security problem occurred."

Just to experiment I renamed vserver-ppc-s1-exec to just vserver (as this page suggests: http://hacks.oreilly.com/pub/h/571) but it didn't seem to make a difference.

I also tried launching it with the following command:
./vserver > /dev/null 2>&1 &
...but again, it didn't make a difference, I still get this "security problem."

Any other ideas appreciated.

Fofer
04-02-2004, 04:00 AM
Well, I figured it out, after some thinking outside my box, and actually paying attention to the WMP error: "security problem."

(I was barking up the wrong tree when it came to looking at vserver and whether or not it was running. In then end, it had nothing to do with that.)

After looking through WMP's security settings, I suddenly realized I was connecting to TiVoWebPlus via my external URL (through dyndns.org.) That's when the "security problem" came about.

As soon as I connected instead using the TiVo's internal IP (10.0.1.9) -- it works fine. (D'oh!) Since the bandwidth requirements for the full stream are high, I'll only be connecting to vserver when I'm on my LAN anyway.

Hopefully my boneheaded mistake will help someone else in the future.

Now on to tackle tystreamer so I can view these shows (compressed for lower bandwidth) when I'm on the road! :)

paulgreenfield
07-30-2004, 07:32 PM
I would like to be able to access my Tivo from the internet and can login to TivoWebPlus thru my firewall using the Orenosp reverse proxy server exposing port xxxx which gets translated to 80 for the Tivo. Everything is fine until I click on View then I get the "security error". Presumably I need to expose a different port for the WMP access to the Tivo? Any ideas appreciated.

lart2150
07-30-2004, 11:51 PM
raw ty streams are not good for streaming over a internet connection. you do need a diffrent port for vserver but a better way to do this is etivo http://www.dealdatabase.com/forum/showthread.php?t=34314 it will encode your shows to a lowerbitrate so you can stream it over the internet