PDA

View Full Version : tivowebplus question



wejones
04-14-2004, 05:14 PM
I've been trying all day to uncompress tivoweb plus, but it keeps indicating that there is a crc error in the .gz file. Ie I unzip the .zip file on the PC, and transfer the files to the tivo. I then run the extract-tgz program to extract the .gz file.... everything OK to this point. However, when I try to use gzip to uncompress the .gz file, it says that the archive is corrupt.
I have also tried running the .tpm file directly, but it gives the same result, ie it extracts the .gz file, but says it is corrupt when it tries to uncompress it.
I know that people frown on using winzip to uncompress .zip files of things that are to go to the TIVO, but I've never had a problem with this before, and I don't know of another way around this,if it is due to using winzip.
If people think my problem is due to having used winzip, I do have access to linux, if someone would suggest the program they use to unzip the file from linux. However I really suspect that there is a problem with the file I downloaded, even though I've downloaded it several times now, and I've actually re-zipped it, and compared the crcs for the files in the 2 zipped versions, and they are all the same.
So, my main question, is , is there another source where I can download the tivowebplus final version file, or perhaps an earlier version of the program that I can try? I'd really like to find a place where I can download the .gz version rather than the .tpm version, but I'd just like to find a version that isn't corrupt.

thanks

gtrogue
04-14-2004, 05:38 PM
Make sure your uploading it as binary.

wejones
04-14-2004, 05:50 PM
Make sure your uploading it as binary.

Yes, I'm using WS_FTP in binary transfer mode. I've never had problems with it before. I may try moving a few binaries over though, just to make sure that the ftp process isn't messing up somehow.
I tried using the very old dos pkunzip program to unzip the zip file, in case winzip is doing something strange, but it can't handle the long file names.

Thanks.