View Full Version : Jumpy playback with SVCD

07-05-2004, 10:07 AM

I've done a lot of reading on the forums and even more experimentation with the extraction, burning a lot of coasters in the process. I'm a little confused as to the extraction process and what happens during which stage.

I have TyTools alpha 9 v 14 and a DirecTivo. I'm able to setup the tyserver end of it and get tytools to connect and get a listing. I'm able to grab a .ty onto the computer, make a key file, edit the key file to remove the commercials (GOPEdit), and then make it into an mpg for SVCD burning.

When playing the resulting mpg on my computer, it plays fine with absolutely no jumps or skips and the audio stays in sync. However, when burning it a CDR (using Nero 6) the resulting SVCD exhibits jumps or skips during playback and sometimes the audio goes out of sync only to get back into sync a while later. This was with a Samsung DVD/VCR combo player.

The jumps and skipss almost always occur while something is happening in the scene as opposed to a more static scene during the show. For example, I'm trying to get a MacGyver episode (Deathlock) to SVCD. During the scenes where there's just dialog between two characters, everything is fine (though audio sync can sometimes be wrong). But during the scenes where there's action going on, the playback is amost certainly jumpy.

I'm sure that I'm doing something wrong because of a misunderstanding of the process. I'm confused as to when the "Patch audio holes" should be on. Should that be on while I'm downloading the original ty from the Tivo? Also, a couple options within TyTools confuse me. During the final multiplex step, should I be choosing 'Multiplex Files' or 'Multiplex (New Format) 2' from the File menu? Should I ever be switching the Network Options to 'Multiplex Mode' instead of 'TyStream Mode' within the File menu?

Here's the settings with which I downloaded from the Tivo, I'm making assumptions about the relevant options, please correct me if I'm wrong:

=File menu:
TyStream Mode
(No other relevant settings)
=Edit menu:
(No relevant options)
=View menu:
(No relevant options)
=Options menu:
====Make .TXT File
====Verbose Level 1
====VCD/SVCD Mux Output
====Transcoding - #2 - sVCD - 44.1 @ 192
====DBI Socket (new mode)
====Use .m2a

(Should I have had "Patch Audio Holes" enabled during this initial download phase?) Any other settings that I should be using? I'm confused as to why the mpg plays back on the computer fine, through Windows Media Player no less, but then gets wonky when burned as an SVCD.

Any help, suggestions, or pointers are appreciated.

07-05-2004, 03:18 PM
First of all, the most likely culprit for the skipping and jumping is a bitrate that is too high for the SVCD spec and for your player. That particular problem will not be noticable on a computer because it doesn't have to spin a CD (the files were on the hard drive) and because it doesn't have the limitations of a set top player. Check the output and see what the bitrates are (to see if they are too high). When my bitrates get too high for my STP I ususally hear a high-pitched sqeal (squeak).
If all else fails, pick up a new player that handles your output better (Cyberhome, APEX..check the STICKY). Try before you buy (or go somewhere with a liberal exchange program).

I would tend to pick the Multiplex Files (the new muxer has issues that have been fixed but not released).

Yes, you should Patch Audio Holes, but you do that during the MUX not during the extraction.


07-05-2004, 04:11 PM
Another possible culprit is that your dvd player doesn't like reading your CD-Rs.

If you have the capability, I'd suggest testing with CD-RWs (rather than going into the coaster business)