PDA

View Full Version : TCL/Tivo and TCL Libraries



jonwilson030981
07-05-2004, 01:51 PM
I have now decided to try to implement things in TCL due to the problems I was having trying to compile C code. I have two problems, one minor and one slightly more important.


(1)
I have the usual UNIX magic at the top of the file...

#!/tvbin/tivosh

But when I run my test file with "./test.tcl" I get...

bash: ./test.tcl: No such file or directory


(2)
I am trying to use some TCL libraries, notably tclsoap, tcldom and tclxml. But when I run my script I get...

can't find package SOAP::Domain
while executing
"package require SOAP::Domain"
(file "test.tcl" line 3)

I have added the directories for the inflated zips I downloaded to the TCLLIBPATH variable, but that doesn't seem to help? Do I need to run a make? Even though I intend to run the pure TCL implementations of the libraries?

Many Thanks for any help.

Jon Wilson

NutKase
07-05-2004, 04:55 PM
But when I run my test file with "./test.tcl" I get...

bash: ./test.tcl: No such file or directory

I'm assuming that you're using a 'unix aware' text editor?

NutKase

jonwilson030981
07-05-2004, 05:58 PM
I was using Notepad in WinXP, I guess the different line feed characters could be to blame. I will try another editor.

Jon

sanderton
07-06-2004, 06:46 AM
Not sure how many of the "standard" TCL libraries are in TiVo's implementation - it's quite an old version too so just adding libraries from a current install probably won't work.

Look at some other hacks source, and the libraries on the TiVo HD for hints.

BTUx9
07-06-2004, 02:59 PM
AFAIK, tivo disabled the ability to install external packages in tivosh.