PDA

View Full Version : Strange behavior using tytool, stumped



angra
10-08-2004, 03:45 PM
Everyone,

I've been having some very strange behavior when trying to use tytool lately. I have 9r17, a series 2 dtivo, running tserver_mfs7_mips. I have been able to succesfully extract and conver to mpeg in the past with this setup, which is what I am trying to do. Lately, things have not worked so well.

First, about 4 weeks ago, I tried an extraction of a ~4GB video via tytool get in "TyStream" mode. I got a few seconds in to the download and then tytool suddenly quit. I tried it again, and sometimes it quits right away , and sometimes I get progress reports like the one below:


looping total = 9994361 mbytes (77 seconds) [86370.27 meg/sec] 00:-01:-55 remaining...


for a while before quitting. But, almost all (all?) ty downloads via tytool are crashing out for me now. I accidentally left tytool in vsplit mode one time, and just before the status meter flipped out, I got the following in the output window:



Unknown PES packet. Fix it dear henry...
type = 0x0

PTS Reset Detected... Correction in progress...

WARNING: Encountered a damaged SeriesII Video Frame!
Unknown PES packet. Fix it dear henry...
type = 0x0
Unknown PES packet. Fix it dear henry...
type = 0x8
Unknown PES packet. Fix it dear henry...
type = 0x65
Unknown PES packet. Fix it dear henry...
type = 0x83


Since I was desparate in a hurry to extract this particular video, I downloaded the .ty via mfs_ftp, and then used tytool mux to conver it to mpeg, which worked just fine.

However, in the last week or so, _that_ has even stopped working. When I use tytool to mux a .ty file that I downloaded, the first ~515 MB work just fine, but any .ty that is longer than that long results in a mpeg file that is always no more than about 514MB.

I am totally stumped. I can't find any reference on here to someone else having dealt with these symptoms. Anybody have a clue, hint, idea for me?

oh, I also noticed, when I launch tserver_mfs7_mips, I get the following errors on my console:


crc mismatch len=17408 0xb5d29bfd 0xada2152d
crc mismatch len=9216 0x58b7ca8a 0x52536ce9

angra
10-09-2004, 06:24 PM
I tried "split file" on a long .ty. I got lots of:



Main Pump: Bad Chunk! Skipping!
Main Pump: Bad Chunk! Skipping!
Main Pump: Bad Chunk! Skipping!
Main Pump: Bad Chunk! Skipping!
Main Pump: Bad Chunk! Skipping!
Main Pump: Bad Chunk! Skipping!
Main Pump: Bad Chunk! Skipping!


I have no idea what to make of this. All .ty more than ~515MB are not working properly. Seems suspiciously neat 512MB.

kkeala
11-21-2004, 02:29 AM
I started having the same problem around the same time! Weird.

First, the crc error for tserver is normal.

It seems that something has trashed tytool's and mfs_ftp's abiliity to concatenate the individual ty files properly.

Anyway, I don't know if you have tried this, but I just now used mfs_ftp to get the tmf file, extracted the ty parts and then just concatenated them myself.

The windows console command is "copy /B part00.ty+part01.ty+...+part0n.ty resultfilename.ty"

Take luck!

captain_video
11-21-2004, 01:14 PM
Each FSID is 512MB or sometimes a little less. It sounds like it's choking on trying to extract multiple FSIDs (i.e. a complete ty file). I'd try reinstalling the tserver_mfs7_mips and NowShowing.tcl files on your DTivo to see if that helps.

angra
11-21-2004, 02:46 PM
As it turns out, my problem is specific to my main workstation. Something in the networking connection between tivo and PC is causing all sorts of problems. Etivo doesnt work properly on this machine, tytool totally dies, and even mfs_ftp is a bit unreliable (as I mentioned). I have worked around this problem by using another one of my machines to do the network transfers.

I've tried just about everything I can think of short of rebuilding the OS on this machine, which I will do eventually. Installed new network cards/drivers, uninstalled and then reinstalled tcp/ip in windows. Uinstalled every program that seems network interface related and reinstalled. nothing.

Anyone else having similar problems, try using a different PC to transfer, and see if that helps.

johnyg
03-13-2006, 06:47 PM
I have a Dtivo Series2. I had it working great for over a year. Then I upgraded from tytools 9r18 to 10r4 and started getting really weird isssues.

When extracting from tivo I would have:
Looping total = 5 mbytes ( 30 seconds) (.45 meg/sec) 00:05:00 remaining....
then it would jump to:

Looping total = 12345 mbytes ( 31 seconds) (93.45 meg/sec) 00:-05:00 remaining....

I thought that was weird enough. but then when I tried to make key files, I would run into all kinds of errors:

Generating KeyFrame File: C:\TIVORAW\Somevideo.ty
Detected Tivo Type: Series2
Detected Audio Stream Type: MPEG Layer II
Final standardAudioSize = 592
Final standardFrameLength = 576
Final standardAudioDiff = 2160 or 00:00:00.024
First Video PTS: 00:02:40.628

....Unknown PES packet. Fix it dear henry...
New LII audio bug Detected... Correction in progress... 576 != 288
WARNING: Encountered a damaged SeriesII Video Frame!..

DiffTime = 0.671000 (671) == 0.011183 Minutes

total = 7995392 (7 MB)


If I tried to edit the key file, gopeditor would just crash.

So I tried everything to fix this... reinstalled old tyserver... reinstall new tyserver... I even (After some other issues) rehacked my tivo... which is now running v 6.2 software. Nothing worked.

Then I tried to install latest tytools 10r4 on a different pc... that worked. That is great and all, but I want to know why it doesn't work on my main machine that worked for years? Also the other machine is not a good machine to do this on. I was hoping the new version of tytools 10r5 would fix it, but that release seems to be taking some time. I'm wondering why this happen and why more ppl didn't experience this.

Johnyg.

comakid
10-14-2006, 08:11 PM
I have a similar problem!!! Tytools version 9r8 was working great until about 2 weeks ago. I then tried to extract 4 1 hour shows. Did not pay attention to time because it was late and went to bed. Checked pc after comming home from work next day. Still hadn't completed frist show. Aborted process and retired second tivo, it worked. However last night both tivos fialed. Installed tytool 10r4 and tried to extract same 4 shows. Now getting time as 77 plus hours.

I checked the server window and saw the message "warning wired server window size"

I can not seem to find any info on this warning. Can anyone help??
Here is some more info that might help. Pc is running XP pro connected to network by wired switch ( has two computers) going to A microsoft wireless router ( has 3 laptops wireless and two desktops wireless) while the first xbox is connected through switch to same router along with two nas(network attached storage by serverelements.) units. Second xbox is connected through a switch along with a modded xbox to same router. There has been no chnages to my network for over 3 months. The xbox and the servers are working fine. I will try to install tytools on another computer and see if anything changes.
Both tivos are stand alone hdr312 running software version 3.0-01-1000 from december 2005

I also could not visit tytool.com or or www.tytool.com to get any help


Update

Installed tytools on a different computer that hasn' t been running since july and I Got my speed back on the new computer but not the old one. Also I was slightly dyslexic the error message said wierd server window size