PDA

View Full Version : Can't Unlock, Please Help



arthur
09-06-2001, 12:54 AM
I've had my Tivo for couple of weeks now and it's still unplugged (yucks, you're right)
I read all the faqs and a lot of forums just to make sure that I do all the steps right.

My Tivo is Phillips HDR 212 20Hrs Tivo with a built in Quantum Fireball lct 20 (20G drive)

I bought a Maxtor 4K040H2 (40G) for backup.

Followed the instructions in section 2.18 but soon discovered that my Tivo drive is locked,
No problem I figured, I know how to unlock it,
Couldn't do, the damn thing refuses to unlock.

Here's what happens.
The BIOS detects my both drives
Primary Maxtor master as 40G
Secondary Quantum master 9G
dlgchk reports

Int 13 Devices 2
ATA Devices 0
ATAPI Devices 0

Hitting on Display Data gives me
"No IDE drives detected. BIOS test was not performed"
"Press any key to continue"

Device# Cyls Heads Sec/Tracks Total Sectors Capacity
80h 1024 255 63 16450560 8422 MB
81h 9 32 63 18144 9 MB

Device# Cyls Heads Sec/Tracks Total Sectors Capacity
80h 4867 255 63 78188355 40032 MB
81h 9 32 63 18144 9 MB

Where is this 8422 MB coming from?
Shouldn't that be 20GB?

Next I did CTRL ALT DEL and booted into Dylan disk, which by the way saw the quantum as 9MB

repeated all of the above several times, just in case I missed anything, always same problem.


Has any body else had similar problems?
Couldn't find anything os similar on various forums.
One place I read someone using guunlock instead of dlgchk.
Don't know anything about it and have no clue where to find it.

Sorry for the lengthy post, I tried to capture as much detail as possible to ease the expert's diagnosis.

I appreciate a feedback, as I'm anxious to get this baby rolling.

Thanks in advance.

stonybroke
09-13-2001, 01:51 PM
I had exactly the same results from dlgchk myself.Tried two pc's for a change of bios-same result on each.
Then I used qunlock ~40 gb streight off..Joy and I am told the unlock is perminent.
Best of luck.
Ian:)

Lure
09-13-2001, 04:07 PM
what does the boot cd see? the boot cd unlocks the hd too...

there are 3 ways to get around the size problem
1. dlgchk....enter through this prog and ONLY do a hot reboot. after switching the machine on and off it's locked again! (again use crtl-alt-del or reset button to reboot after running dlgchk.exe)
2. manually enter the disk details into the BIOS.
3. run gunlock.exe: this is a permanent solution.

goodluck:D :D :D

Worf
09-14-2001, 12:31 AM
qunlock isn't permanent - the drive will relock of it you boot it up in a TiVo.

Lure
09-14-2001, 09:12 AM
it's details, dear watson , details

arthur
09-14-2001, 05:46 PM
Thank you all who responded.
I used qunlock to get around the problem, after which it was piece of cake.

Worf, you are right, each time the drive is booted in Tivo, it locks it back.

Thanks again to all that responded.
Does dlgchk work for anybody? or was I using it wrong?
I did the ctrl alt del reboot, and at first thought that qunlock needed the same, but it turns out that qunlock requires power off.
Wierd...

Thanks

rhett
10-11-2001, 10:51 AM
I have successfully used dlgchk to unlock a drive. The only problem is that I have another drive that refuses to unlock with either gunlock or dlgchk. Any advice? The Tivo was defective when I got it, so it may be an actual defective drive. I currently have it running on a 40GB WD drive. I would love to be able to use the original drive (40GB) as an expansion disk. Why didn't I ship it back in the first place? Long story.

Lure
10-11-2001, 06:59 PM
all hd companies have diagnostic floppy's try these for the brand/typ of drive you have. It would aleast detect the drive, beable to fdisk and format it. for maxtor the floppy is called "maxblast" in general you would have a little program called dm.exe to check out disks.

if you can't find it or can't understand what's this about: publish the drive brand and type and I'll try to figure out what is going on, what you need.

rhett
10-12-2001, 12:04 PM
The drive in question is a standard Tivo unit. Quantum/Maxtor Fireball LCT HD. I believe it is a 40GB drive, but it may be only a 14hour model. It does register as 9GB(locked). When I try to unlock it, my Bios's SMART drive technology alarm complains that the drive is "possibly corrupt". Gunlock doesn't appear to do anything. Where can I obtain the Maxtor utility?

Lure
10-15-2001, 10:13 AM
download maxblast from the maxtor site:

MAXBLAST (http://www.maxtor.com/Maxtorhome.htm) (choose product suppoert and then software&utillities)

goodluck:D :D :D