PDA

View Full Version : Backup immed after restore fails



scubaboarder
10-20-2004, 04:10 PM
I am a nooB for sure, but have been reading, searching etc. Am also comfortable with PC hardware, Unix, etc. (linux is a bit new to me honestly). This particular problem is part of the bigger picture of doing a 2 kernel monte process. (following William Von Hagen's process)

I have a DTivo Phillips DSR7000/17 hacking to a new Maxtor 120G/7200 drive.

I have found a virgin backup of 4.0.1b-02-2-xxx from apparently an 80Gb SA tivo on eDonkey. If I do the mfs restore, I can boot, go through the Tivo "welcome" process, etc and it all appears to work fine. Network, contact Tivo service, record, etc, etc. The restore command I'm using is:

mfstool restore -C -s 127 -xzpi /mnt/windows/Tivo-S2-4.0.1b-02-2-xxx.mfs /dev/hdc

Later in the 2-kernel hack process I get a variety of errors when trying to do backups, restore 3.1 kernels/rootfs (via dd), etc. Examples include no space on device, fsck failures, etc

So, I thought I'd start at the beginning (again) and see where I ran into problems. Basically, as soon as I do the 4.0.1b restore onto my new drive, I tried to backup the new drive. Using the command:

mfstool backup -6 -o /mnt/windowns/MyTivo401b.mfs /dev/hdc

I get the error:

Backup failed: Unknown error trying to determine partition sizes.

However, I can see the partitions (via pdisk) and mount partitions like /dev/hdc4.

Additionally, I have a 2nd backup of a 40G S2 4.01b system. When I restore and try to backup that version, I get the same results except I get a "Segmentation Fault" error upon trying to do the backup.

Thoughts on why this restore wouldn't work? I'm hoping that if I solve this, other subsuquent issues will be resolved as well.

thx.