PDA

View Full Version : can't read the directions (split from: Newbie 4.x+RID guide)



p40whk
03-20-2005, 12:20 PM
I just finished updating a 200 gb hard drive using HUGE's 4.x + RID instructions and everything seemed to go ok except I get nothing but a black screen! I get audio and all the menu functions work but no picture. I followed the instructions to the letter so I'm not sure what's wrong. I'm using a non-RID box so I omitted the instruction for that.

I'm using an RCA DVR40 reciever
Western Digital 200gb hard drive
I used PTVupgrade's LBA48 boot CD
and I used PTVupgrade's 4.0.1b Series 2 (SA) Image (Model Number TCD240080)

Just to be sure, I checked the tag on the back of my unit and it says DVR40. That doen't necessarily mean that's what's inside the box! I still have the original box and I cross checked the model/serial number info with the unit and I do have a DVR40.

I just spent the last hour searching these forums for "the symptoms" I was having and have yet to find the solution. I am somewhat familiar with linux comands and there are only two areas throughout the 4.x+ RID guide that I get something in question. the first is:

5. Boot your PC off the PTV CD with your new Tivo drive connected.

6. Pop the Tools CD in the drive and type:

# Make a directory to mount drives
mkdir /cdrom
(at this point I get "Cannot create directory '/cdrom': File exists")

Which I don't think is a problem because it lets me mount /dev/hdd /cdrom and run the mfsrestore.


the second issue happens when I run the init_framework command (tar -zxvf /cdrom/init_framework.tgz). When I check the /tivo/init/ directory to make sure the following files are present, the vmlinux.px (lba48_2.4.18.px) file is not there. I ended up using the cp command to copy the file from the CD to the /tivo/init/ directory even though I know the next step (cp /cdrom/lba48_2.4.18.px /tivo/init/vmlinux.px) looks like it does this. Maybe having both files is causing my problem, not sure?

/test.conf
/init/001_bash.init
/init/010_lba48.init
/init/011_uma6fix.init
/init/kmonte.o
/init/monte
/init/vmlinux.px (renamed lba48_2.4.18.px)
/init/uma6fix.o
/init/uma6fix_license.txt

I've searched thru umteen threads with no luck. I have no problems reading each thread and have spent the past week reading as much as I can to do this. I don't need someone to hold my hand, just point me in the right direction.

criticize me if you think it will help but make sure your criticism leads to a newbie learning. I really love learning how to do this stuff but don't want to get so frustrated i end up buying a prepackaged deal.
Edit/Delete Message

bbsux
03-20-2005, 12:25 PM
I've searched thru umteen threads with no luck. I have no problems reading each thread and have spent the past week reading as much as I can to do this. I don't need someone to hold my hand, just point me in the right direction.

This is one thing I hate about DDB. They treat you like an *****...

Anyways, just do a clear and delete everything...

Short and sweet explanation, the image still thiks its on a Standalone... So by clearing it it will realize its in a dtivo and initialize everything...

p40whk
03-20-2005, 12:38 PM
Anyways, just do a clear and delete everything...

Short and sweet explanation, the image still thiks its on a Standalone... So by clearing it it will realize its in a dtivo and initialize everything...

I did do a clear and delete everything and that didn't work. I have started to narrow it down to the dssapp prcedure.


Originally Posted by fixn278
If you have sound and no picture, you have an improper dssapp.

I did not do the steps in red so I'm not sure what my next step would be. I got all of my files from here or downloaded from PTVupgrade.

alldeadhomiez
03-20-2005, 12:43 PM
This is one thing I hate about DDB. They treat you like an *****...

How so?

If anything, it seems that the regulars give people too much credit, by presuming that they have basic troubleshooting, reading, and searching skills.


Anyways, just do a clear and delete everything...

Based on the symptoms he described and the fact that he "followed the instructions to the letter" (heh), I would not expect this to fix the issue.

But I wouldn't be surprised if he got, say, channels 219 and 500...

bbsux
03-20-2005, 12:54 PM
How so?

If anything, it seems that the regulars give people too much credit, by presuming that they have basic troubleshooting, reading, and searching skills.


Because you all seem so condescending (like your statement above). Not everyone is so technical minded as you. Point them in the right direction instead of telling them to read more, and actually help them. At least I tried to do that.

p40whk
03-20-2005, 01:01 PM
he "followed the instructions to the letter" (heh), ...


Sure did! Three times. Granted, I'm not a programmer but I do write SGML and XML aircraft maintenance manuals for a living and do a lot of data manipulation using VB and SED so I am somewhat familiar with understanding this process. I will keep asking questions in the hopes that I will learn. But, what some of you that clearly see the problem don't understand is that some of us are just trying to put all the pieces together and we don't see what you see. I appreciate all comments, negative or otherwise as long as they give me more information to solve my problem.

With Best Buy selling a 160gb drive for $40 I'm tempted to end the frustration and use instant cake and forget about networking my tivo (which I really want to do). I'll keep trying this a few more times and keep reading the forums (there are 623 posts in this thread alone) for my answer but at some point the negative comments will force another newbie to get a bad impression of this community.

bbsux
03-20-2005, 01:06 PM
p40whk: I'd go to the origional Riley thread here (http://www.dealdatabase.com/forum/showthread.php?t=39354)
and download the dssapp there and re-copy it over... It won't hurt. and it just might work... remember to "chmod +x" it

alldeadhomiez
03-20-2005, 01:30 PM
Because you all seem so condescending (like your statement above). Not everyone is so technical minded as you.

That's all fine and good, but this hobby isn't for "everyone." As a hacking community, we have little use for non-technical people (although they are certainly welcome here if they are willing to learn).


Sure did! Three times.

So far I see you've made at least two mistakes:

1. You followed a crappy "guide," disregarding the advice of the DDB regulars.
2. You "skipped the steps in red," even though they are required on a Uma6 board. (Did you really do this three times?)


at some point the negative comments will force another newbie to get a bad impression of this community.

Oh, darn, there goes my bonus. :rolleyes:

JJBliss
03-20-2005, 01:35 PM
...using a non-RID box so I omitted the instruction for that.

I'm using an RCA DVR40 reciever

Are you kidding? :confused:

hayreass
03-20-2005, 01:39 PM
And they say the seniors are never helpful....
Seems like enough info to have a go at a 4th try now.
Possibly with more success....

PlainBill
03-20-2005, 01:59 PM
Are you kidding? :confused:
Perhaps it would be a good idea to make sure the RID (and non-RID) receivers are listed in a very large font on the first page of the support thread.

On the other hand, this kind of s7up|dity is it's own punishment. (Sort of like the time I forgot the chmod a file - twice :o ).

PlainBill

p40whk
03-20-2005, 02:28 PM
That's all fine and good, but this hobby isn't for "everyone." As a hacking community, we have little use for non-technical people (although they are certainly welcome here if they are willing to learn).

I am willing to learn (and i am a technical person) as I've stated in the past, that's why I'm here. So, how did you learn? did you ask any stupid questions? Probably not judging from the responses you've been giving.




So far I see you've made at least two mistakes:

1. You followed a crappy "guide," disregarding the advice of the DDB regulars.
2. You "skipped the steps in red," even though they are required on a Uma6 board. (Did you really do this three times?)

1. Well, there are A TON of crappy guides out there. and it was that crapy guide that suggest I post here with problems. So, without knowing who "the Smart People who write guides" are and reading a lot of conflicting information how the !@# do you know which site is giving you good advice? I did not disregard the advice of the DBB regulars, I asked for their advice and got condesending comments.

2. WOW! an actual hint of how to solve my problem! See, that wasn't so hard now was it? Actually no, I only did the process twice but it ws getting late and i was tired so i wanted to make sure my fingers didn't slip on another key.


Oh, darn, there goes my bonus. :rolleyes:

In all of the posts I've tried to have a little humility and not come back to flame anyone because they insist on giving smart !@# answers (until this post). It is very easy to fire off a nasty response but as a moderator of this forum I would think you're here to prevent this. I've had some great people help me out and others just simply add more useless comment to an already long post. If you don't have anything constructive to add then why post and make people search through hundreds of Non-Technical posts?

alldeadhomiez
03-20-2005, 02:34 PM
Perhaps it would be a good idea to make sure the RID (and non-RID) receivers are listed in a very large font on the first page of the support thread.

I'll do ya one better:

http://www.dealdatabase.com/forum/showthread.php?p=202708#post202708

alldeadhomiez
03-20-2005, 02:49 PM
So, how did you learn? did you ask any stupid questions? Probably not judging from the responses you've been giving.

Those are the same kinds of responses I should expect if/when I ask stupid questions on a technical forum. That's life. Don't take it personally.


1. Well, there are A TON of crappy guides out there. and it was that crapy guide that suggest I post here with problems. So, without knowing who "the Smart People who write guides" are and reading a lot of conflicting information how the !@# do you know which site is giving you good advice? I did not disregard the advice of the DBB regulars, I asked for their advice and got condesending comments.

Seems you were more than happy to blindly follow a (bad) guide without doing the research ahead of time, and then lash out at others when you goofed up. Nice work. :rolleyes:


2. WOW! an actual hint of how to solve my problem! See, that wasn't so hard now was it?

It would've been even easier (and less stressful) for you to read the support threads and solve the problem on your own... no?


If you don't have anything constructive to add then why post and make people search through hundreds of Non-Technical posts?

Pretty much everything you need to know is in the release thread (http://www.dealdatabase.com/forum/showthread.php?t=39354).

p40whk
03-20-2005, 04:52 PM
Funny, I thought this was the newbie thread where "If you just got your tivo, or are new to tivo hacking, your question definitely belongs here. This includes essentially all questions like "can i" or "where do i find", etc."

Didn't see the discaimer warning newbies to expect being subjected to ridicule. Awe shucks Goober!

alldeadhomiez
03-20-2005, 05:00 PM
Didn't see the discaimer warning newbies to expect being subjected to ridicule. Awe shucks Goober!

Yep, looks like you jumped right in without reading much of anything, then you copped an attitude. Now that you've made a complete fool out of yourself, go back and read:

http://www.dealdatabase.com/forum/showthread.php?t=37756 (A1,A3,A7,B4)

Edit: split to Sewer.