PDA

View Full Version : Fedora Question



DocTauri
03-23-2005, 02:55 PM
My server was previously loaded with RH9, I would use this box to xfer files via mfs_ftp, the name of the downloaded file would be complete, and life was good. I've since rebuilt the box using Fedora Core 3, now when I download files w/mfs_ftp, my file names are only the first word until the space. For example, if I see this in the mfs_ftp listing:
{The Outer Limits}{1995-05-05}{Virtual Future}{06.00 AM Mon Feb 24, 2003}{SCFI}.tmf

Under my new system, it downloads as:
The

I realize this is a RH issue, not a Tivo one, but does anyone have a clue as to how I correct this?

Thanks,
Doc

Jamie
03-23-2005, 03:44 PM
My server was previously loaded with RH9, I would use this box to xfer files via mfs_ftp, the name of the downloaded file would be complete, and life was good. I've since rebuilt the box using Fedora Core 3, now when I download files w/mfs_ftp, my file names are only the first word until the space. For example, if I see this in the mfs_ftp listing:
{The Outer Limits}{1995-05-05}{Virtual Future}{06.00 AM Mon Feb 24, 2003}{SCFI}.tmf

Under my new system, it downloads as:
The
What FTP client are you using?

DocTauri
03-23-2005, 04:10 PM
Just the generic ftp command line client that installs with FC3, not sure the version #. RPM says: ftp-0.17-22.

Thinkdiff
03-23-2005, 04:28 PM
You can name it yourself..

get "{The Outer Limits}{1995-05-05}{Virtual Future}{06.00 AM Mon Feb 24, 2003}{SCFI}.tmf" "{The Outer Limits}{1995-05-05}{Virtual Future}{06.00 AM Mon Feb 24, 2003}{SCFI}.tmf"

First file name is the remote file, second is the local file.

DocTauri
03-23-2005, 04:30 PM
True, just curious why it stopped working across versions (curiousity coupled with laziness ;-)

Jamie
03-23-2005, 04:31 PM
Just the generic ftp command line client that installs with FC3, not sure the version #. RPM says: ftp-0.17-22.Works fine for me, if I quote the name in the get command.

You might want to try a different ftp client (lftp, ncftp). I've used both with FC3.

Also, see the ntrans and nmap options in the ftp man page, e.g. to replace ' ' with '_', if desired.

oakwcj
03-23-2005, 05:50 PM
I use gftp -- which is included in the Fedora Core -- without any problems. It's also a good ftp client for Tivo transfers because it can be set to always transfer in binary mode and to maintain file permissions.

Gunnyman
03-24-2005, 09:02 AM
I think there is a setting in your bash profile enabling long file names. Do other File Names with spaces work ok on your system?

DocTauri
03-24-2005, 07:29 PM
I think there is a setting in your bash profile enabling long file names. Do other File Names with spaces work ok on your system?
It doesn't appear to be a long filename issue

<CORRECTION> I get whatever is between the first set of braces as the name, so in my example above, the name actually is "The Outer Limits", but the braces are stripped, and everything after the title is gone.

Can't find gftp on the system, will have to look through the rpm's, and I couldn't get lftp to work, kept timing out when trying to xfer the file. I'm sure it's a problem with the interface between the seat and the keyboard, as the regular ftp transferred it.

On a whim, I unloaded the version of FTP that loaded with FC3 and loaded up the one from RH9 (ftp-0.17-17) and it worked as expected...

Now I'm really confused, as Jamie's FC3 ftp worked too.