PDA

View Full Version : Broken state: Some show parts unscrambled while others not



TasteBuds
07-21-2005, 02:39 AM
I'm using s2_unscramble (in-place unscramble method) and have successfully unscrambled a couple of shows. I just tried to do another and encountered a problem.

I ran rew.tcl, generated a shell script to mfs_rewrite each of the 5 parts and ran it. Everything appeared to work, so I ran AW's csoscout.tcl, but it didn't change anything. ciphercheck.tcl still reports the show as Encrypted Yes. This leads me to believe that not all parts of the show are unscrambled.

I still have the CSOs in place (as confirmed by exploring the MFS metadata using TivoWeb), but I cannot play back the show anymore (immediate "Delete Now?" screen, followed by "no video stream" error message on the Tivo) :( .

I suspect that when I "primed" the show, perhaps not all part keys were cached by the kernel mods and that now some parts are unscrambled while others remain scrambled. Am I correct?

Any ideas on what can I do to better diagnose the situation and get the show back to either a fully scrambled state or an fully unscrambled state from here?