PDA

View Full Version : Tserver help



blacksheep
07-26-2005, 01:50 AM
I have a direct tv series 2 running version 6.2. I have the tserver and NowShowing.tcl files on the var/hack dir. When I try to start the server I get the error failed to open []
Not a Tivo super block! (magic=0x00000000)

What the heck did I do wrong. Could use a bit of help please.

jjz
07-26-2005, 02:15 AM
Did you use the version of tserver here (http://www.dealdatabase.com/forum/showthread.php?t=39487) ?

blacksheep
07-27-2005, 12:04 AM
No I didn't. Got tserver from the batbd disk from the Hacking The Tivo book. I was able to get the file containg tserver but I failed to mention I am a pc user and i believe bzip2 is for linux. I need to find this tserver program in a format I can extract. May have to load Linux up on one of my machines.

captain_video
07-27-2005, 08:11 AM
WinRar will extract bzip2 files in Windows just fine.

blacksheep
08-03-2005, 11:49 AM
I have the new version of tserver on my tivo in the correct location. When I try to start the server I get:

Telneting to the TIVO...
Connecting to '192.168.0.93'
Connected...
We got 'bash-2.02# ' which is the prompt!
bash-2.02# /var/hack/tserver.c -s /var/hack/NowShowing.tcl
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: line 24: syntax error near unexpected token `usage(v'
/var/hack/tserver.c: line 24: `void usage(void)'

I don't understand why it does this? I'm positive its not a directory but a file.

eastwind
08-03-2005, 12:09 PM
I have the new version of tserver on my tivo in the correct location. When I try to start the server I get:

Telneting to the TIVO...
Connecting to '192.168.0.93'
Connected...
We got 'bash-2.02# ' which is the prompt!
bash-2.02# /var/hack/tserver.c -s /var/hack/NowShowing.tcl
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: //: is a directory
/var/hack/tserver.c: line 24: syntax error near unexpected token `usage(v'
/var/hack/tserver.c: line 24: `void usage(void)'

I don't understand why it does this? I'm positive its not a directory but a file.Are you trying to execute the .c source file? You need to use the executable instead.
The new version of tserver doesn't require the NowShowing.tcl file to be external. Try changing the Execute String to /var/hack/tserver.

ew

blacksheep
08-05-2005, 01:13 AM
That worked. I now have tserver working but now I need to disable the file scrambling encryption. I got this drive from ptv upgrade believing it was set to not scramble the files. Yeah right! How do I do this on a series 2 tivo running 6.2 software. I'm sure it posted somewhere.

Thanks to :) all who responded.

NutKase
08-05-2005, 01:21 AM
I got this drive from ptv upgrade believing it was set to not scramble the files. Yeah right! How do I do this on a series 2 tivo running 6.2 software. I'm sure it [is] posted somewhere.

Try the p t v upgrade forum (http://forum.ptvupgrade.com/index.php).


NutKase