PDA

View Full Version : Horrible extract speeds via s1 cachecard



dtivo_user
10-19-2005, 07:45 PM
Hi,

I've own a DirecTiVo Series 1 with a CacheCard installed. I've installed TivoWebPlus, mfs_tools, and unscramble. Although everything seems to work, downloading any video from the tivo to my PC is extremely slow, only about 15Kb/sec. I am donwloading the file using a linux box running "wget --no-passive-ftp". It is slow from the start, even after a TiVo reboot.

I'm not sure what to even try to fix this problem.

Some diagnostic info:
bash-2.02# hdparm -v /dev/hda

/dev/hda:
multcount = 16 (on)
I/O support = 1 (32-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
nowerr = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 16383/16/63, sectors = 268435455, start = 0

bash-2.02# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Bcast:127.255.255.255 Mask:255.0.0.0
UP BROADCAST LOOPBACK RUNNING MTU:3584 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 coll:0

eth0 Link encap:Ethernet HWaddr 00:0B:AD:69:C6:67
inet addr:192.168.1.9 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:190942 errors:0 dropped:0 overruns:0 frame:0
TX packets:281588 errors:0 dropped:0 overruns:0 carrier:0 coll:0
Interrupt:29
bash-2.02# nic_config_tivo

TiVo TurboNet/AirNet/CacheCard on Tivo Configure - 20050218

Copyright 2002-2004 Silicondust Engineering Ltd. All rights reserved.

Detecting TiVo hard drive...

Detecting TiVo partitions...
Active kernel partition = /dev/hda3.
Inactive kernel partition = /dev/hda6.
Active root partition = /dev/hda4.
Inactive root partition = /dev/hda7.
Var partition = /dev/hda9.

Determining software version...
Philips DSR6000 DirectTV TiVo running 3.1.0c2-01-1-001

Remounting root partition...
Root successfully remounted as writable.

Checking installation type...
Configuring CacheCard installation.

Checking script...
Complete.

Current/New Configuration:
mac address = 00:0B:AD:69:C6:67
ip address = 192.168.1.9
ip subnet mask = 255.255.255.0
ip gateway = 192.168.1.1
debug level = off
cache statistics = 0 seconds



Any ideas?

huntercr
11-08-2005, 04:17 PM
have you ruled out the obvious stuff, like a crappy cable?

What about connecting with an interractive ftp client to look for problems?
Also do you get any related output on mfs_ftp log files?

I get slightly more than 1 Mbytes/sec on my series 1, ( with cachecard, etc ) so you definitely have a problem.

Have you tried (temporarily ) unplugging everything else from your switch except for the tivo and the PC ? ( and replacing the cable )

Also check on the PC side for collisions even though none showed up tivo side ( with netstat )

If you have alot of collisions, I would try forcing your duplex to "half" on both hosts. ( or getting a better switch ). If you have alot of errors, check cables...

That's about all I can think of for that. I know I've repeated myself alot here :)

Good luck!

Charles

satguymtl
11-09-2005, 04:24 AM
Really? I'm getting 25 Mbps (over 3 MBps) with mfs_ftp, and I usually get over 40 Mbps (over 5 MBps) with TyTool 9r18 on a Series 1 DTiVo with CacheCard.

dtivo_user
11-09-2005, 12:05 PM
Hi huntercr,

I've checked all the cables and the switch, and just to be sure I tried using a different switch with different cables. They are all working fine, no collisions, no errors, full speeds (~80Mbps with 2 PCs).

I'd love to see 1MBps on my DTivo!

Any other ideas?

sanderton
11-10-2005, 10:28 AM
You should get over 2Mbytes/sec.

Have you tried connection with a Windows graphical client like SmartFTP? I'd be tempted to eliminate the client form the suspect list.

dtivo_user
11-10-2005, 12:17 PM
I've tried a variety of clients, including Windows explorer (passive and non-passive), linux FTP, linux wget, Hummingbird FTP explorer for windows, Windows commandline FTP, and Firefox FTP plugin, all produced poor results with passive connections performing even worse (5KB/sec).

Thanks for the suggestion though.