View Full Version : Problem with unscrambling

12-02-2005, 12:56 AM
I have a dsr6000 that I am trying to get some old scrambled recordings off of. I was getting the (Failed to get the first 10 initial chunks) so I figure this is a scramble issue. I install unscramble.o , but when I try to insmod unscramble.o it says (error reading ELF section headers) . Unscramble.o is not in running when I check in modules. Thanks for any help.

12-03-2005, 04:41 AM
sounds like you transferred the unscramble.o in ascii mode instead of binary.


12-03-2005, 06:46 PM
Thanks for the tip.

Ok, I transfered the file in binary. I am still getting the (Failed to get the first 10 initial chunks) message. I don't think I've transfered any of my files in binary before, so could there be a problem with another file that was transfered in asci?

12-05-2005, 07:09 PM
Unscramble shows up when I check modules, so I have no idea what to try next? Is there any other method to extract these scrambled recordings? This is a DSR6000 that is no longer subscribed so there won't be any additional recordings, if this matters?

12-10-2005, 04:35 AM
Ok, I finally got it to work using mfs_ftp to pull a show off. I can use tytool to make a key file with no errors (finally:D ) and gop edit. But I still can't extract using tytool? I'm just curious why the unscramble is not working in tytool?

12-30-2005, 10:21 PM
anyone figure this out yet? I'm having the same problem, but will just pull it with mfs_ftp wierd....

01-23-2006, 08:47 PM
Same here, worked via mfs_ftp but not tytool - but as long as mfs_ftp worked, I'm not concerned, since I was then able to create the keyfile etc. in tytool, and since this is really just a workaround to get my old stuff off before I delete it from the tivo.

04-01-2006, 12:15 AM
I have a DSR6000 S1 v3.1.0-01-1-001

I added Turbonet Card that I had purchased several years ago, installed TWP, mfs_ftp ect. I started extracting the shows when I realized that they were scrambled.

So I found, xfered to DTivo, chmod'd and ran UNSCRAMBLE.o (insmod unscramble.o)

Played about 10 to 20 seconds of the show,
used TyTool v9r18 to xfer the show,
Clicked MAKE KEY FILE(s)
Then clicked EDIT KEY FILE(s)

I then got the following error: ...ShowName.ty is NOT GOP Editor Key File

I ASSUME that its because TIVOAPP hasnt been patched. Well I have search mosr EVERY thread concerning it.

I have searched and searched only finding one post:IS version: 3.1.0-01-1-001

http://www.dealdatabase.com/forum/showthread.php?p=139455&highlight=3.1.0c2#post139455 #13
3.1.0 S1 is file offset 0x476248

So is this correct?
echo -ne "\x48\x00\x00\x38" | dd conv=notrunc of=tivoapp bs=1 seek=4678216

I have searched and searched AND searched. IF anyone has the answer or idea PLEASE reply. I wanna unscramble & extract these shows (about 48 of them) So I can swap this DTivo with a newer unit. ThankS!

04-01-2006, 08:53 PM
I am having the same problem. Tytool will not extract, mfs_ftp will. however then I take the .ty file, open it Tytool, make/edit keyfile and go to multiplex, the resulting MPG file is typically about 2/3 the length it should be. The MPG plays fine, it is just short. Am I missing something?

1Dave1 - I am far from an expert but are you sure it has anything to do with tivoapp? Try installing msf_ftp and extracting with unscramble.o loaded and then try to generate your key file in TyTool from the resulting .ty file.

04-01-2006, 11:18 PM
I tried it with unscramble loaded, I play a few seconds of each show the using TyTool I pull each show ONE AT A TIME... No Problem, Make the Key file... No Problem, Edit The Key File.... Freezes and give the "ty is NOT GOP Editor Key File" Error.

I read and read yesterday evening from about 7pm until after 3am. Its my understanding that TivoApp MUST be patched BEFORE loading unscramble so unscramble can do its job.

The TyTool GOP Editor Error is being caused by the show STILL BEING SCRAMBLED when trying to edit the keyfile.

Since this is a Series 1 DSR6000 running v3.1.0-01-1-001 I am even considering attempting to chance an upgrading to a higher version (3.1.1b,c) in hopes of finding the offset to patch Tivoapp with so unscramble will work..

I have well over 50 music programs that I do not wish to loose and after I manage to extract them I am going to trash the drives, rehack the DTivo with version 2.5.2 and store it for later use.

04-01-2006, 11:41 PM
AFAIK if the shows were still scrambled you could not download them via TyTool...you would get an error message saying it could not read the first 10 bytes or something similar. I am also running a series 1 DSR6000. I could not get unscramble.o and TyTool 10 to work (it worked fine a year or two ago...I took a break from hacking it). But as the others have posted, loading unscramble.o and then using mfs_ftp to download the files via ftp results in unscrambled files (although I am still having problems with some of them).

if you are trying to convert to mpeg, and don't care about editing out the commercials, you don't even need to generate a key file. Just go to TyTools, select "Process: Multiplex File(s)" and select your .ty file. If you are hoping to upload back to the tivo, there are other formats via mfs_ftp to download where you do not need to edit it.

hope that is helpful.

04-02-2006, 12:28 AM
I guess I am ALL CONFUSED now. lol

Well I AM able to pull the shows to the computer via turbonet card and make key files using TyTool with NO ERRORS.

I only get an error when I attempt to edit a key file.

This is with or without running unscramble.o

I just now found this post:(#100)

Update: I can confirm that the following alphawolf's steps, with the following mod
echo -ne "\x48\x00\x00\x38" | dd conv=notrunc of=tivoapp bs=1 seek=4678216
worked like a charm on S1 Dtivo 3.1.0-01-1-001

I turned off noscramble in Xplusz
xp #47,0
did the backup / mv / restore / patch to tivoapp
cleared the cache
ran csoscout

and here's the update ciphercheck results.

/var/hack# ./ciphercheck.tcl
TmkLogger: <134>Feb 1 17:46:52 tcl[346]: Tcl created pool of 1458176 bytes

TyStream encryption is currently disabled.

BUT! In a post from Alphawolf (#2): http://www.dealdatabase.com/forum/showthread.php?p=139455&highlight=3.1.0c2#post139455


Well I just followed all of those instructions that I found, and when finished I ran ciphercheck.tcl. It says that encryption is enabled!

04-02-2006, 03:35 AM
I just ran across something posted by NUTKASE, post # 6: http://www.dealdatabase.com/forum/showthread.php?t=39312&highlight=upgrade+dsr6000+3.1.1c

You can't patch a running tivoapp.

Did you rename tivoapp to something else and in another directory like

cp /tvbin/tivoapp /hack/tivoapp.patch

cd /hack

echo yada yada tivoapp.patch

mv /tvbin/tivoapp /tvbin/tivoapp.tmp (We'll delete this in a minute to avoid filling up our tivo)
mv /hack/tivoapp.patch /tvbin/tivoapp
cd /tvbin
ls -l

Look for tivoapp and tivoapp.tmp and ensure they're rwx.

So I am understanding that I need to cp tivoapp to a new file name (like tivoapp.tmp), patch that file new name(echo -ne "\x48\x00\x00\x38" | dd conv=notrunc of=tivoapp.tmp bs=1 seek=4678216) , then mv tivoapp.tmp back to the original tivoapp

Seems reasonable, any thoughts?

If not, then I have no idea what I am missing!

04-02-2006, 10:52 AM
back in the day there was "noscramble" and "unscramble". One turned off encryption, allowing future programs to be recorded unencrypted. The other did not change how the tivo recorded - programs were still encrypted - but it allowed you to un-encrypt them when downloading.

"unscramble.o" is for programs that have been recorded encrypted, like yours (if I understand right). The steps you are taking are basically for "no encrypt" - future programs will be recorded unscrambled - however you will be unable to watch the encrypted programs you are trying to save.

It's important to know which one of these you want to do, they're not compatible and they do different things.

04-03-2006, 04:09 PM
I am trying to UNSCRAMBLE exsisting shows that ARE SCRAMBLED on s S1 DTivo

I have read every thread that I can find and as you know one thread leads to another and another.

I have tried just running unscamble.o (insmod unscramble.o) and have has no change in results.

I am able to pull the shows to my computer via TyTool with NO PROBLEM. Its when I got to "make key file" I get the "GOP EDITOR ERROR"

If I pass making a key file and just "make vob" then I get the "10 chunks" ERROR.

There was one instance that I was able to pull a show, make a key file, edit the key file and make the vob but I am not 100% sure what steps I had taken to get that result. Since then I can pull shows but thats it.

I do NOT wish or care to stop the scrambling of new show(reworking the dtivo after this), I just wanna pull the exsisting scrambled shows off for archiving.

04-08-2006, 05:31 AM
Still no success even after using insmod unscramble. I can play 20 seconds, pull the show with tytool but recieve an error when trying to view, convert to vob or make a key file.

I have exhausted ALL the threads with anything remotely associated with unscrambling and extracting.
Any other suggestions??? anyone?

04-14-2006, 03:56 PM
Still no success even after using insmod unscramble. I can play 20 seconds, pull the show with tytool but recieve an error when trying to view, convert to vob or make a key file.

I have exhausted ALL the threads with anything remotely associated with unscrambling and extracting.
Any other suggestions??? anyone?

Any success with unscramble.o? I saw your other post (http://www.dealdatabase.com/forum/showthread.php?t=48806) that says you got it working, but it is dated before this post. So I was a bit confused.


04-16-2006, 05:33 PM
sorry, was on vacation for a while.

all I can say is this: I have the same dtivo, and this works:

install unscramble.o (lsmod unscramble.o)

install mfs_ftp, make sure it is running

go to your tivo. select the show you want. Run the show for five seconds, then pause it. If you don't do this, unscramble doesn't work.

use an ftp client to connect to your tivo. Go to the ty directory. Download the show that you just paused. note I said FTP client NOT tytool.

I end up with a .ty file on my hard drive. I then open it in TyTool client (make a key file, make an mpeg, whatever). It works. It has become unscrambled in the process of downloading.

Did you try these exact steps? Do NOT try to download via TyTool! I have not been able to make unscramble.o and tytool behave together.

not trying to keep harping on this way of doing it, just sharing what I have been able to make work. If you do it this way, you don't even have to have tyserver running on your tivo, just mfs_ftp.

04-21-2006, 01:40 AM
Well I have done everything BUT use an FTP client to attempt to download a show. I honestly have never tried it that way. I use CuteFTP to xfer files from my computer to my DTivos, I would assume that would work to xfer shows as your describing,

I used windows FTP and xfered a show, YEP tytool made the key files ect.

Thanks! for a simple answer in the right direction, after days & days unscramble.o & Tytool defintely doesnt work together.

04-21-2006, 05:03 PM
Well semi-success, CuteFTP will NOT connect to port 3105. I also tried CORE FTP LITE, It wants a user id and password for the tivo.

I tried ftp'ing in windows explorer, I have success obtaining a connection using: (ftp://192.168.1.xx:3105/) All directories including /TY can be viewed. I can then select a show, but when I try to xfer or copy the file to a folder on my computer I get a full file name but a 0 size file.

I did try ftp'ing into one of my S2 DTivo's and was able to xfer a show to the computer with no problems at all.

On the S1:
mfs_ftp IS installed, chmod'd and in the rc.sysinit.author, it shows up in hackman and IS running.

I will continue to do some more searching for the answer.

01-21-2007, 03:34 PM
Anyone know what the process is for recordings that were made pre version 3.5?

I have been reading posts and trying different methods for the past three weeks. Since the S1 3.5 upgrade I am using unscramble.o to unscramble current recordings and successfully pulling them off to my PC using both mfs_ftp and TyTools but still unable to pull pre 3.5 recordings off. Even my old TyStudio works (without cuts). This is my old HNS GXCEBOTD and I would like to archive my old recordings and start from scratch.

01-21-2007, 03:42 PM
I don't think the process is really any different. The recordings are in MFS and scrambled.

You need to boot an unscramble kernel (series-2 requires something like monte, but I don't think you need it for S1).
Once booted up, play each video for a few moments to break the scramble key.

Then you should be able to download the recordings.

01-25-2007, 11:35 PM
Narf- Thanks for the reply. I am guessing it must be an issue with the unscramble.o. I applied the offset for tivoapp and both encrypted and CSO are set to no for all recordings done after the offset was applied, according to ciphercheck. I will keep plugging away to see if I can find a soluion.