PDA

View Full Version : Incomplete recordings when using MFS_FTP



fi3ndlich
12-23-2005, 11:35 PM
I am having a strange problem with mfs_ftp. After I download my recordings whether it be with smartftp or etivo the .ty files come over without issue however they are not complete. Instead they are only about half the size they should be as far as time goes. I have had a 1 hour show only be 20 minutes a couple only 30 minutes. I have read all kinds of articles on this forum but have only found one which exactly described my issue but no one said how to fix it. The article I am refering to is http://www.dealdatabase.com/forum/showthread.php?p=208239&highlight=complete#post208239

I am running mfs_ftp 1.2.9p with s2bins.tar installed too. I followed the instructions as described however the only thing I could not download was the mfs_stream file located here.
http://www.dealdatabase.com/forum/showpost.php?p=128731&postcount=1
it says that the link is broken. Now either this is what I need and will fix my problem or I am still missing something. I am experiencing this issue on a DTivo 3.1 and also on a DTivo 6.2. Both versions are acting the exact same way.

Please advise so I can get this working properly.

If you need more information about my set up or what I have tried please let me know and I will post all I can.

Thank you.

eastwind
12-24-2005, 03:28 PM
You could get the newer mfs_util* package in the file section. It has a "fixed" mfs_stream.

ew

fi3ndlich
12-25-2005, 08:00 PM
I looked in the files section and the only mfs_ftp stuff I found was either what I currently have or what perhaps looks like source that needs to be made. I could be wrong but since you seem to know what I need could you paste the link to what I need?

Jamie
12-25-2005, 11:57 PM
I looked in the files section and the only mfs_ftp stuff I found was either what I currently have or what perhaps looks like source that needs to be made. I could be wrong but since you seem to know what I need could you paste the link to what I need?Grab the mfs-utils_bin.mips package here (http://www.dealdatabase.com/forum/showthread.php?t=39487). Follow the instructions in that thread for using with the unpatched mfs_ftp.

fi3ndlich
12-26-2005, 11:52 AM
Jamie,

Thank you for your response. I went to that link and downloaded the file you suggested. As I read though the post I am confused as to how I am suppose to install/patch my mfs_ftp install.

I copied over the 5 files it listed into my mfs_ftp folder and then I ran the ln -sf mfs_import mfs_stdinsert
from within my mfs_ftp folder. Everything seemed to take and I can see the shortcut when I ls my folder

when I went to run mfs_ftp.tcl i got a permission denided which I then chmod 755 it along with the files I copied over adn ran it agian. It was then able to launch however I cannot connect.

I must be dumb and missing something. Were those 5 files the only ones I needed to move over?

Jamie
12-26-2005, 12:21 PM
I do not understand how to make a symlink. I have never done that before and I do not want to screw anything up and the insturctions on how to do it were not written for a person like myself with limited linux experience.Wikipedia symlink page (http://en.wikipedia.org/wiki/Symlink).

FAQ: How do I create a symbolic link? (http://help.hardhathosting.com/question.php/95)


when I went to run mfs_ftp.tcl i got a permission denided which I then chmod 755 it along with the files I copied over adn ran it agian. It was then able to launch however I cannot connect.There's no reason why changing the mfs_* binaries should have stopped mfs_ftp.tcl from working. It should not have changed the permissions on that file. Sounds like you messed something else up. In general, the port.3105.log file is the log to check for mfs_ftp errors.

ScrappyDoo
12-27-2005, 12:50 AM
I had the same exact problem, fi3ndlich (until just a moment ago). Very frustrating. I downloaded the mfs_utils source file and applied the jaime patch. Then I got the MIPS binaries for my HDVR2, copied over the five files (export,import,stream,tarstream,uberexport) into my mfs_ftp folder, and the symlinked mfs_import to mfs_stdinsert from that folder with this command:

ln -sf mfs_import ./mfs_stdinsert

and viola, it finally works! I'm not sure why the s2bins for mfs_ftp don't work anymore for you or me, and I hope they can be fixed, rather than having to jump through these hoops. But with my paltry knowledge and the assistance of everone here at dealdatabase, I have done more with my DTiVo than I ever thought possible. I hope you get your mfs_ftp running correctly. Good luck!

cheer
12-27-2005, 01:05 AM
I'm not sure why the s2bins for mfs_ftp don't work anymore for you or me, and I hope they can be fixed, rather than having to jump through these hoops.
So far as I am aware, development on mfs_ftp isn't occurring. This is a hobby, remember. :) In the grand scheme of Tivo hacks, installing Jamie's mfs_* binaries is pretty trivial.

ScrappyDoo
12-27-2005, 01:08 AM
Maybe it's trivial for you "Diamond Members", but not for us slow "Members in Training"! Hehe

fi3ndlich
01-01-2006, 07:29 PM
I would just like to thank everyone for helping me get this working. I am now able to extract files and play them completely by following the instrucitons listed above. I do however have one more questions that I am sure if I dig far enough on this forum I will find the answer but if you know it off hand or know the link please reply with it. Like I said I can download just fine now however I cannot upload back to tivo. I was under the understanding that if I copy off the tmf file I should be able to upload the tmf file back to the tivo to view it. The reason I wish to do this is I have several movies I owuld like to put back on another tivo. I tested this by just recording a 30 minute show. I downloaded the TMF file and then deleted the show on tivo. The next step I tried to upload the tmf back to the tmf folder however i get a permission denied like it is read only or something. Any ideas.

Again
Thanks for all the help.

brndnkjns
01-01-2006, 11:43 PM
The next step I tried to upload the tmf back to the tmf folder however i get a permission denied like it is read only or something. Any ideas.

Try the suggestions in this thread (http://www.dealdatabase.com/forum/showthread.php?t=43827)

fi3ndlich
01-02-2006, 12:52 PM
I followed that post earlier and still was unsuccesful at uploading a file back to tivo.

Any other suggestions?

Jamie
01-02-2006, 01:07 PM
I followed that post earlier and still was unsuccesful at uploading a file back to tivo.

Any other suggestions?Start by capturing a level 5 log from the mfs_ftp server. Set info(dbl) to 5 in mfs_ftp.tcl and settings.tcl and examine the port.3105.log file after a failure.

rc3105
01-03-2006, 04:39 AM
So far as I am aware, development on mfs_ftp isn't occurring. This is a hobby, remember...
sure it is, the last stable public release is what's getting stale. upto my elbows in diapers for a while so there's not really time to debug & field the 2^10-23 questions updates allways prompt :eek:

various installs are evolving based on tivo type (nearly one of everything from sas1 through hdtivo & 2.0/2.5 burners) video source (sat c-band, dtv, dtv-hd, ota-hd, usb webcam & tuners, xvid feeds via rss / newgroup / torrent) inspiration (sure would be nice if it did <whatever>) and available time

there are 30+ forks, the merge is going to be interesting :D