PDA

View Full Version : Tytool Bus error



billrehm
01-07-2006, 07:27 PM
I'm trying to get Tytool 10.3 to work on my Directivo 6.2. I have ftp'd tserver to the /var/hack directory on the tivo unit. (see below)

bash-2.02#
bash-2.02# pwd
/var/hack
bash-2.02#
bash-2.02# ls -l *
-rwxr-xr-x 1 root root 158776 Jan 7 22:42 tserver
bash-2.02#
bash-2.02#

When I try to start the server from the client I get the following

Telneting to the TIVO...
Connecting to '192.168.1.103'
Connected...
We got 'bash-2.02# ' which is the prompt!
bash-2.02# /var/hack/tserver
Bus error
bash-2.02#
bash-2.02#

I have also tried to start the server from within telnet (cmd ./tserver) with the same Bus error. Either way when I try to "refresh" I get a "Failed to Connect" error message.

I'm not sure what else to try, I have tried rebooting several times with the Tivo unit on, in standby. I even had my daughter type the command thinking I was doing something else wrong. Any advice is much appreciated.

cheer
01-07-2006, 07:39 PM
Perhaps a symptom of not transfering the tserver file in binary mode? Have you tried downloading the latest TyTool and re-uploading tserver to your Tivo?

billrehm
01-07-2006, 09:52 PM
Thanks cheer, I will give it a shot, but I think you might be right, thinking back I don't recall forcing binary when I did the FTP I bet it went ASCII.

Thanks again!

billrehm
01-07-2006, 10:02 PM
Bingo that was it, I guess I had a bit of a brain fart! Now to see if I did a better job at disabling the scrambling on my dtivo box.

Thanks again for the advice!

cheer
01-07-2006, 11:45 PM
No problem -- I expect we've all done that at least once. :)

If you ran the superpatch67, then encryption should be disabled.