PDA

View Full Version : Exception in TyTool 10r4



Cyphon00
06-10-2006, 03:51 AM
When I try to generate a key file or mpg file for a 1 hour episode of Lost I get this error then TyTool generates an exception.

FileInfo:


FileName: {Lost}{2005-11-30}{What Kate Did}{10.00 PM Wed Nov 30, 2005}{KTNVDT}.ty+
Size: 6.81 GB (7,315,928,328 bytes)
Detected Tivo Type: HDTivo
Detected Audio Stream Type: Dolby Digital 5.1
Final standardAudioSize = 5888
Final standardFrameLength = 0
Final standardAudioDiff = 6480 or 00:00:00.072
First Video PTS: 11:15:25.110


TyTool Errors:



......49100.........49200.........49300.........49400.........49500

.........49600.........49700.........49800.........49900.........50000

.........50100.........50200.........50300.........50400.........50500

.........50600.........50700.........50800.........50900.........51000

.........51100.........51200.........51300.........51400.........51500

.........51600.........51700.........51800.........51900.........52000

.........52100.........52200.........52300.........52400.........52500

.........52600.........52700.........52800.........52900.........53000

.........53100.........53200.........53300........Unknown PES packet. Fix it dear henry...
type = 0xCB
Found an OOB packet... The Audio Diff is: 12:19:32.215
sAud is: 00:00:00.000
largestAudioPTS is: 12:19:32.215
Is it in sequence??? It is OFF by exactly 1386631.718750 frames.
Nope... Not in sequence... Skipping it...

.

***** Detected an AUDIO type change! From Unknown to Dolby51 *****
Unknown PES packet. Fix it dear henry...
type = 0xDA



I have the full *.txt file from the process if need be, but it's almost a megabyte so I didn't think it was a good idea to post here. If anyone has any ideas how I can get past this please let me know. I'm extracting this from my HR10-250 with mfs_ftp. I will try it direct using tserver and TyTool and see if it helps. Though I've done 6 other Lost episodes like this without any real difficulty.

cheer
06-10-2006, 12:24 PM
This is OTA HD, right? TyTool has some issues with some OTA streams, especially the audio goofiness that lies within.

I know Josh is aware of the issues and there are fixes coming, but not sure when he'll have the next update out (real life occasionally intrudes).

You might try using hdemux/mplex -- I've had that work on a couple of streams that cause TyTool to GPF.

Cyphon00
06-11-2006, 02:02 AM
Yes, it's OTA HD with a not-so-good antenna. I did try hdemux/mplex and it crashes out pretty quick with:


Assertion failed: pts != -1, file hdemux.c, line 658

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.


I tried tserver to a ty file and got the same crash in TyTool. Guess I'll hold off on this episode for a while.

vurbano
06-27-2006, 07:11 PM
That episode bombed on me too a long time ago.

Cyphon00
07-02-2006, 11:41 PM
I was finally able to get around it. I wrote a little program to remove the 128*1024 byte sections that were causing the crash. Once I narrowed down to the sections that caused the problem I cut them out and reprocessed with TyTool. From then on everything worked out normal.

flagmaster
07-25-2006, 02:51 PM
Im runing into this problem with just a few files once in a while, most OTA HD stuff converts just find to mpg.

Can you give me a idea of how you fixed this or maybe share with me your code and how to implement it?