PDA

View Full Version : editing commercials from recordings in the tivo: was "mfs_ftp?"



F1 Fan
08-12-2006, 09:00 PM
I want to cut out the commercials so i can make some room so ive done a little bit of reading and got what i need,my question is,can i ftp the folder of mfs_ftp and the part from Chunedit thats need it to the correct place in the tivo?and if i can ,where does it goes?


BTW the tivo is hacked so i can ftp to it and do what ever

Thanks
________
PROGR?S (http://www.toyota-wiki.com/wiki/Toyota_Progr?s)

BLKMGK
08-12-2006, 10:54 PM
Alright, as it happens I'm working with MFS_FTP right now so I'll share what I *think* I've figured out. In the past I've used MFS_FTP to pull .TY and Ty+ files off and have tinkered with them. Normally I use TyTools to pull shows and to edit them however - usually destined for my PSP via FFMPEG.

Tonight however I'm using MFS_FTP to pull off TMF files, TMF files are actually RAR archives with a .TY file inside (possibly multiple chunks), and an XML file that describes the show details. I am unsure as to what effect editing the .TY file will have - I can post some of the XML if that would help, chances are some of it is posted in the MFS_FTP support thread already though. I think it would be fine, I seem to recall reading as much although there is Timestamp info within the XML. BTW, I see something called Commercial Offset in there too so fingers crossed that one day it could just be setup to skip for you? Not familiar enough with it to say one way or the other.

Anyway, I've not yet done this but from what I've read I will be able to MFS_FTP *up* the TMF files and that the daemon on the TIVO will parse them correctly using the XML file contained in the TMF - mind you at 2meg per sec it's taken forever to download them so I sure hope thisworks! In a few hours I'll know for sure - I've got a new drive ready to go into the box and my Season Passes and channel line-up backed up. I'm moving from 4.2x to 6.2 BTW so fingers crossed everything rolls okay, I note that there's version info in the XML files. Worse comes to worse I've got TivoServer running under Cygwin to serve up the content once HMO and MRV are working. :D

Hope that helps!

BLKMGK
08-13-2006, 05:39 AM
MFS_FTP on 6.2 is a bit of a PITA to say the least. First you have to get the binaries, then you need updated binaries for MIPS if you have an S2, then there's an additional file tzoffset.tcl file to add. THEN you have to edit the MFS_FTP.TCL file to comment out instances of "event send $TmkEvent" since events have apparently been removed from 6.2. Lastly there's reference to creating a symlink between MFS_Stdinsert and MFS_Import to send calls for mfs_import to mfs_stdinsert. Prior to that symlink I get broken pipe errors. After doing that symlink I get log entries that it cannot execute ./mfs_stdinsert....:rolleyes: The symlink command was -> ln -sf mfs_import mfs_stdinsert which forces an overwrite of mfs_stdinsert that is supposed to pipe to mfs_import but on my box it isn't - chmod maybe??:confused: (See my P.S. below!)

Anyway, I've been working on this problem for multiple hours now. Information on getting mfs_ftp working on 6.2 is scattered all over the place in pieces it seems. http://www.thewallens.net/Zipperwiki/index.php?title=Extraction_Tutorial#chubb.27s_step-by-step_guide_for_running_MFS_FTP_on_your_S2_DTIVO.2FHDTIVO
<- has some good info but there are also a TON of threads here that explain it and as of right now it's NOT working on my TIVO. Apparently the license for the code will not allow someone to simply fix it and post it for folks to install but some people on a planet far far away have actually gotten it to work. Perhaps after some sleep I will too but my lack of success sure isn't from lack of trying. Sadly the woman returns tomorrow and my surprise upgrade isn't likely to be seen quite so kindly since none of our shows have gotten back on the box:eek: SeasonPass restore is also hitting bumps with local shows - it says I don't have them but I can sure see them :lol:

P.S. Okay so going over this piece by piece to give you details I spotted something. I had renamed mfs_import - hard to explain why but it was a mistake. I have renamed it back and holy crap it looks to be working!:eek: Now for the fun part - it took me over a DAY to transfer my files off and speed is now something like 1/3 but I knew it would be slower. <shrug> Hopefully this will help you and others. I'm sorry I've not linked to file locations etc. but it's pretty spread out and i'm exhausted - it's about 6am. If that's REALLY needed lemme' know but the files are all here if you search a bit. The URL I did post will help....

F1 Fan
08-13-2006, 09:29 AM
wow:confused: :confused: :confused: it seems to me you have a full plate,never the less thank you for your effort to help me out,that link its going to be very helpfull,i just woke up and going to put a few hours on my little project:) Hope you get yours going soon.

Thanks again
________
GM COLMOTORES SPECIFICATIONS (http://www.chevy-wiki.com/wiki/GM_Colmotores)

BLKMGK
08-13-2006, 02:00 PM
Heh, check the P.S. - while writing all of that out for you I was forced to retrace all of my steps. When I did so I tried the one thing I hadn't done on my second install which was to create the Symlink - when I did I cat'd the log file and saw that it couldn't find the file at the end of the link. I checked and it had been renamed :o while I was trying other things. Truthfully I think I misunderstood how the Symlink worked and thought it wasn't done right - hard to explain. Anyway, by renaming the file back correctly the symlink worked and I was in business!

Mind you if you're not on 6.2 then it's easier, earlier code has the events in it so no manual editing is required.

For 6.2 here's a quickie way to go about it... Download\install the latest MFS_FTP. Get the MIPS files and use them to overwrite some of the binaries in the MFS_FTP install directory. Get the latest timeszone offset file tzoffset.tcl and overwrite the one in the MFS_FTP directory. Edit the MFS_FTP.tcl file to comment out all lines that begin with "event send $TmkEvent" which is an event structure that is apparently not longer in the code with 6.2. Lastly, create a symlink-> ln -sf mfs_import mfs_stdinsert which forces an overwrite of the mfs_stdinsert file with the link file.

Yes, it took me HOURS to figure this out searching high and low, I found several posts with my EXACT errors but no solutions posted that were clear so I hope this helps you and others. You will have to check that the correct files are "executable" with chmod, you will have to edit the mfs_ftp.tcl file with a text editor that is UNIX text aware to keep extra crap out, and there amy be other pitfalls to avoid that I'm not aware of but this ought to get you in the right direction. The earlier URL I pointed to has links to several posts with code and much of this info although spread about a bit. Do also search rather than just use those URLs to make sure you have the latest code. Tivoserver is also something to look at IMO since it emulates a TIVO and you can use MRV to watch files rather than reinsert - I still wanted to reinsert though for the WAF.

Not to invite a deluge of requests but if folks get stuck I'll try to help them as best I can. I learn best by screwing up but 8 hours straight through the night is a bit nutz even for me.:eek: mfs-FTP on 6.2 seems to be working fine for me so far, having said that I should probably have backed up the drive once it was all dopne beofre I began reinserting a zillion shows! :p At least I'm now on current code enjoying new features on my DTIVO. Oh and this isn't a "guide" :rolleyes: it's simply my way of sharing what I learned so that perhaps others won't spend the time I did banging their heads against the wall - it's nice when info is in one place.

P.S. Once working you'll find that putting the TIVO to sleep ups transfer speeds. Down on 4.x I was getting 2megs max while watching shows and now on 6.2 UP I am getting 860K max. Up will always be slower because it's having to parse apparently and yeah my USB drivers are good.

BLKMGK
08-13-2006, 02:06 PM
Oh some hopefully helpful tips - while in the mfs_ftp directory "cat log" will show you the log file for MFS_FTP. "ps aux" will also show you what threads are running so if you find errors in the log and need to make changes you can find the PID (process ID) of the running MFS_FTP (there will be several) to stop it. "kill pid#" will kill the running process but make sure you use the right PID. ;) "chmod" is another command you might need if something doesn't run because it's not executable but I'm not sure if "chmod 755" or 777 is correct so if you have issues research that!

NOT a Linux expert by any stretch (be gentle) but I'm teachable so I'm slowly absorbing this. My TIVO is mostly an appliance overall but all the things in my home I've hacked run some sort of embedded Linux and I sometimes wardrive so I'm picking it up! :P

F1 Fan
08-14-2006, 06:50 PM
wow that is very helpfull and all in one place:),could you tell me what usb driver you're using?my speed is about .52meg it takes for ever to transfer anything,and im at 6.2 if it helps


"NOT a Linux expert by any stretch (be gentle) but I'm teachable so I'm slowly absorbing this. My TIVO is mostly an appliance overall but all the things in my home I've hacked run some sort of embedded Linux and I sometimes wardrive so I'm picking it up! :P"sounds alot like me there isnt much left at my house that i havent hacked:)


BTW you have been very helpfull,Thanks again
________
Chevrolet lumina (http://www.chevy-wiki.com/wiki/Chevrolet_Lumina)

BLKMGK
08-15-2006, 10:19 PM
You've probably got the older drivers, the ones from TIVO aren't so hot as I recall. I don't recall offhand which drivers I'm running but most any of the newer ones posted in this forum would probably help you! If you get really stuck lemme' know via PM and I'll see what I can do to help.