PDA

View Full Version : Directtivo reboots



mvasquez
12-09-2006, 10:45 AM
I need some help here. i have been scanning this forum for days trying to get some info on unscrambling recordings so i can download to my PC using TyTool and watch/record them. I applied a patch and was able to get the recordings to download and multiplex correctly but now when I watch them on the Tivo itself, the box reboots. I have a Directvio series 2 running 6.2-01-2-151. It has been upgraded/networked with a pre-configured drive from PTVupgrade. Here is what I did:
• cp /tvbin/tivoapp /tvbin/tivoapp.orig
• cd /tvbin
• mv tivoapp tivoapp.tmp
• cp tivoapp.tmp tivoapp
• chmod 755 tivoapp
• echo -ne "\x3C\x02\x00\x00" | dd conv=notrunc of=tivoapp bs=1 seek=1602412
• echo -ne "\x10\x40\x00\x2b" | dd conv=notrunc of=tivoapp bs=1 seek=6713220
• echo -ne "\x24\x10\x00\x01" | dd conv=notrunc of=tivoapp bs=1 seek=2804900
• rootread
• reboot

Then I read this had to be done as well:
• echo -ne "\x3C\x02\x00\x00" | dd conv=notrunc of=tivoapp bs=1 seek=10705308

I am pretty computer savvy but not the best in Unix. Any ideas where i went wrong or what i can do to fix the problem??
Also Superepatch67 has been applied

ScanMan
12-09-2006, 12:37 PM
I'd say your borked your tivoapp. All you needed was the superpatch which has the patches for 6.2. All of those echo statements are redundant including this 'echo -ne "\x3C\x02\x00\x00"' which you applied in two different places. Restore a stock tivoapp, apply the superpatch and you should be good to go. As far as unscrambling shows previously recorded while encrypted, as you've guessed, you need to setup a monte to an S2_unscramble kernel (good keywords to search on) and go from there...

mvasquez
12-10-2006, 01:03 AM
I copied tivoapp.orig back to tivoapp and all is well again. Thanks for the nudge in the right direction....peace