PDA

View Full Version : mips build of cvs



Jamie
10-17-2007, 01:36 PM
Here' are mips and ppc builds of cvs. This could be useful if you are working on TivoWebPlus and want to check the CVS tree out directly on your tivo. TWP checkout details here (http://www.dealdatabase.com/forum/showpost.php?p=289191&postcount=26).

Built from the cvs-1.11.22 sources. ppc build contributed by n4zmz

PortlandPaw
01-28-2008, 07:51 PM
I've tried the ppc version using
cvs -z3 -d:pserver:anonymous@tivowebplus.cvs.sourceforge.net:/cvsroot/tivowebplus co -r v2-1 -P TivoWebPlusas well as
cvs -z3 -d:pserver:anonymous@66.35.250.90:/cvsroot/tivowebplus co -r v2-1 -P TivoWebPlusand am getting an "illegal instruction" error.

I believe the file is OK as I can view all the --help screens.

Any ideas, anybody?

Jamie
01-28-2008, 10:17 PM
Could be this (http://www.dealdatabase.com/forum/showthread.php?t=41248) issue.

I guess the ppc build is still a work in progress. I'm not really set up to compile and test S1 programs.

PortlandPaw
01-30-2008, 10:09 AM
Jamie, thank you, your link fixed it. A little more specifically, to get cvs running on a Series 1:

1. Download the ppc version of cvs and put it somewhere -- I recommend /var/hack/lib to be consistent with the next step.
2. Go to Tim's TiVo Software (http://homepage.ntlworld.com/maxwells.daemon/tivo/compiler.html#libc) page and follow the directions to install the C Library. Note that the downloaded file has the wrong extension -- should be .tgz. And use the tar command to unpack it, ignoring any chown errors.
3. telnet to the parent directory where you want TivoWebPlus to appear (rename the old one out of the way). i.e. if you want /usr/TivoWebPlus, go to /usr
4. Run the following command:

cvs -z3 -d:pserver:anonymous@66.35.250.90:/cvsroot/tivowebplus co -r v2-1 -P TivoWebPlus
5. This should run for a while and build TivoWebPlus.
6. For subsequent updates, just run "cvs update" from the TivoWebPlus directory. The anonymous stuff is stored and used.

And thanks to SteveT for helping me get this running -- it's a big help!

IcedTivo
03-01-2008, 06:33 PM
I did all the above and when I run the cvs command in /var/hack I get "bash: cvs: command not found"
I tried renaming cvs-pcc -> cvs still same. does /var/hack/lib need to be in the path or am i missing something else? I did set / rw when i did the export LD_LIBRARY.... cmd

kevin

PortlandPaw
03-01-2008, 08:07 PM
You got it ... add a PATH statement to rc.sysinit.author.

IcedTivo
03-01-2008, 08:24 PM
Thanks Dave, that worked (so far)! I added it to .profile . See what happens next...

kevin