PDA

View Full Version : Linux tools to interface wtih Series 3?



kmt
01-12-2008, 06:13 PM
Are there any native Linux tools for taking advantage of MRV/TTG/TTCB?

lktivo
01-23-2008, 12:21 PM
Google for pyTivo... Allows TTCB from anything that can run Python and FFMPEG ( which is practically everything ).. I'm running it on CentOS 5

LK

playerx
01-24-2008, 05:49 PM
I'm happy to say pyTivo works great in Gentoo!

ronnythunder
01-24-2008, 05:51 PM
moved to support forum

ronny

lrhorer
01-25-2008, 03:57 AM
I'm running galleon 2.5.2 under Debian Etch and I love it. It puts TiVo Desktop badly to shame. It's the only server which allows the user to initiate TTG transfers to the PC from by any Tivo on the network from any TiVo on the network. In other words, if you have 3 series 2+ TiVos on the network, you can sit at any one of the TiVos and select programs to be transferred from all 3 TiVos. There are some 26 4th party applications for galleon, including Weather and Traffic reports which beats the native Yahoo reports all to pieces, and a music app which can look up album covers and lyrics from the internet while the music is playing.

Of course running any application under Linux as a service is a snap, so both pyTiVo and Galleon blow TiVo Desktop right out of the water, IMO.

kmt
01-25-2008, 10:38 AM
Well I'm eager to try Galleon, but I've run into a problem. I've tried registering and posting to the Galleon forum, but that fails and no one seems to be managing that forum.

So here is my problem

With java 1.6 on either Ubuntu Gutsy or Solaris 10 I get when the server starts up

Exception in thread "JmDNS.ServiceBrowser: _http._tcp.local." java.lang.IllegalArgumentException: service name has the wrong type: name=_http._tcp.local., type=_http._tcp.local.
at javax.jmdns.ServiceInfo.<init>(Unknown Source)
at javax.jmdns.JmDNS.getServiceInfo(JmDNS.java:199)
at javax.jmdns.JmDNS.getServiceInfo(JmDNS.java:185)
at org.lnicholls.galleon.gui.MainFrame$NetworkDialog$TiVoListener.addService(MainFrame.java:2933)
at javax.jmdns.JmDNS$1.send(JmDNS.java:818)
at javax.jmdns.JmDNS$ServiceBrowser.run(JmDNS.java:882)
at java.lang.Thread.run(Thread.java:619)

If I run "test" out of the gui/settings I get a similar traceback, and no tivo's found.

However, the togo menu does pick up a nameless tivo at the correct IP address, but the busy cursor never clears and nothing shows under recorded.

lrhorer
02-03-2008, 12:31 AM
Have you browsed the logs in /var/log/galleon? They may hold a clue, especially wrapper.log. I had all sorts of issues with the Java wrapper until I got the correct versions of all the files installed. This doesn't look like the same problem I had, but if the log files don't point to the problem, dig into the galleon script to make sure the environment is being set up correctly. On my system , for example, the version of uname on the system did not recognize the switch being used to determine the architecture.