PDA

View Full Version : Guide to consolidating a Series 3 TiVo without losing any recordings



Thom
07-12-2008, 02:38 PM
I have now consolidated 3 different Series 3 machines from a 250GB+750GB configuration to a single 1TB configuration without losing any recordings.

To do this, you will need a version of the MFSLive v1.3b backup utility that has been patched to allow it to work properly with a Series 3 dual drive set.

I've attached a patched backup utility to this message. Unzip it and copy the file s3backup to a cd or a floppy disk.

A single byte in the backup utility needed to be changed, from an ascii b to an ascii c. After searching the backup utility with a hex editor for an ascii b, I changed the seventh b to a c.

In my examples below from my Series 3 backups and restores, my system uses the following drive assignments:

hdg = cdrom
sda = destination A drive (1TB)
sdb = source A drive (250GB)
sdc = source B drive (750GB)

Attach all your drives to your computer and boot from the MFSLive CD.

Once booted, you will need to mount and copy the s3backup utility into /usr/sbin on your computer. In my case, I removed the MFSLive cd from my cdrom drive, and put in a cd that I had burned the s3backup utility onto. Then I used the commands:

mount /dev/hdg /cdrom
cp /cdrom/s3backup /usr/sbin

Personally, I like to run a couple of quick tests before I begin the actual copy process, which took about 8 hours on my machine.

My first quick test to make sure I can read the source hard disks:

s3backup -o /dev/null /dev/sdb /dev/sdc

If successful, my second quick test to make sure I can write the destination hard disk:

s3backup -qo - /dev/sdb /dev/sdc | restore -i - /dev/sda

If successful, my actual full copy command (which took about 8 hours):

s3backup -qTao - /dev/sdb /dev/sdc | restore -i - /dev/sda

At the end of the copy process, I received a message Attempt to write across partition boundary!, but it didn't affect anything.

Once the copy is complete, the new drive is still not ready for use. If you were to install it now, you would get a Wrong External Storage Attached message on your Series 3.

Use pdisk on the hard disk to modify the partitions:

pdisk /dev/sda

Press lowercase p to display the partitions on the hard disk. You should see 16 partitions, with Apple_Free being the 16th partition.

Write down the length of the Apple_Free partition (partition 16). This will be referred to as length16.

Now delete partitions 15, 14, and 13:

d 15 d 14 d 13

You can delete them all on one line like above, or you can delete them individually. Start with 15 and work your way to 13.

Now display your partitions with lowercase p again. The Apple_Free partition is now partition 13.

Write down the new length of the Apple_Free partition (partition 13). This will be referred to as length13.

Subtract length16 from length13, and write it down. This will be referred to as length14.

Press uppercase C to create a new partition. Do not use lowercase c as it will not allow you to specify the partition type.

13p will be the starting block. (13p just means use the start block currently assigned to partition 13.)

The length will be the length14 number you calculated.

"Second MFS media region" will be the name of the partition, INCLUDING the quotation marks. If you don't include the quotation marks, only the word Second will be used, and the rest will be discarded.

MFS in uppercase letters will be the type of partition.

Now press p to display your new partition info.

Compare the length of the current Apple_Free partition (should be partition 14) to the length16 number. They should be identical. (Basically, you are checking to make sure that you made the new partition 13 exactly the same length as the old partitions 13, 14 and 15 combined.)

If they are not identical, you made a mistake somewhere. Exit pdisk with a q command, then start pdisk again and try again.

If they are identical, then press lowercase w to write the new partition layout to the hard disk. You will have to answer y to the warning message.

Press q to exit pdisk.

You are done with the hard disk. Install it in your Series 3.

When your Series 3 boots for the first time on the newly consolidated and repartitioned hard disk, you will see a Missing External Storage message. This is expected. Simply follow the on-screen prompts to press the clear button, then to press the thumbs up button three times and to press the enter button.

It will take about 5 minutes to remove all reference to the external drive and reboot.

You will not lose any recordings. They are are still on the newly expanded partition 13 of the A drive.

To add a second drive at a later time, run fixdivorce on the A drive, then use mfsadd to add the second drive.

- Thom

ciper
07-28-2008, 06:21 PM
Thom : Quite awesome. Did you figure out this partition combining trick yourself? Do you think a similar method would work with an S1/S2 to migrate them to a single internal drive?

wdwms
07-29-2008, 12:18 AM
Very cool.. this is running right now on my S3 consolidation.. 250 + 160 going to a 500gb... 3.2 hours to go.. time for bed. :)

Thom
07-29-2008, 12:42 PM
Did you figure out this partition combining trick yourself?
No. I first learned of it when Jamie mentioned it in a thread here on dealdatabase. He first learned of it on some other forum which no longer exists.


Do you think a similar method would work with an S1/S2 to migrate them to a single internal drive?

Yes, but not in the same exact way. I've used the partition consolidation trick on a series 1 DSR6000 combo box or two, but I had to manually hexedit the partition pair list in one of the application partitions.

If I remember correctly, I had a dual drive DSR6000 which already had 6 pairs (the max) of MFS partitions (3 pairs per drive), and I wanted to upgrade to larger drives. I copied the dual drives to a larger pair of dual drives, then used pdisk to rearrange the partitions (as mentioned in my guide). Since the series 1 did not have an auto divorce utility built into it, I had to then open partition /dev/hda10 (I think it was a10) with a hexeditor, find the partition pairs (listed in plain text near the beginning of partition hda10), and blank out the references to the now non-existant partitions with spaces. This editting causes a checksum or CRC mismatch, but the TiVo ignores it and works anyway. MFSTools would not run due to the mismatch, but Jamie wrote a tool that fixed it, and MFSLive now has fixdivorce which also fixes it.

The above paragraph was written from memory, so take with a grain of salt. Search dealdatabase and you may find a message from Jamie where he discusses it.

- Thom

Jamie
07-29-2008, 01:18 PM
The original post was on alt.org, which is dead now. Apparently it wasn't archived in the wayback machine. I probably can dig up the scripts I used in the past, but I don't really recommend going down this path.

danajmbabi
09-20-2008, 06:51 PM
Like to try that on a tivo HD. The trick u are adressing works also on it?

Cheers