PDA

View Full Version : Help with mfs-utils and Permissions



jjjones
09-16-2009, 09:15 PM
Following the roadmap here, I have telnet, ftp, tivotools and tivoapppaches up and running on my tivohd. After trying to use any of the mfs_utils included in tivotools, I realized that I needed a mfs-utils.64 version.

Having located the file in this thread (http://www.dealdatabase.com/forum/showthread.php?t=39487), I ftped over to /tivo-bin, which is located at the same tree level as /sbin /tvbin and /tvlib.

When I tried to rename any of the mfs_utils files as backups prior to ftping over the mfs-utils.64 version, I was denied the ability. Renaming from filezilla yielded as follows:


Status: Renaming '/tivo-bin/mfs_uberexport' to '/tivo-bin/mfs_uberexport.old'
Command: CWD /tivo-bin
Response: 250 Directory change successful.
Command: RNFR mfs_uberexport
Response: 500 Syntax error, command unrecognized.

When I tried the mv command from a bash prompt, I got:
mv: cannot move 'mfs_uberexport' to 'mfs_uberexport.old': Read-only file system.

So I examined my /etc/fstab:


# Copyright (c) 2001 TiVo Inc.
/dev/hda4 / ext2 ro 1 1
/dev/hda9 /var ext2 rw 1 2
/dev/hda8 swap swap defaults 0 0

I then changed hda4 to rw, rebooted and checked that the edits took.

Unfortunately, I am still getting the read-only file system error.

I have chmods of 755 for /tivo-bin and the relevant files in that directory.

Could I have a bad umount /tivo-bin from my MFSLive install of the hacks?

Also, is simply replacing the tivotools version of mfs_utils with a binary ftp of the corresponding mfs-utils.64 version the correct way to get mfs_utils working as tivotools has already done the install?

Thanks.