PDA

View Full Version : Must be doing something wrong installing hacks.



dthomas1234
11-16-2009, 02:49 PM
I have been able to upgrade my Series 2 Tivo's hard drive no problem. But I have tried now with multiple different walkthroughs and boot cd's to install hacks and get shell access and tivoweb installed. Every way I have tried it, my USB stops working and it won't detect my Linksys USB100M network card anymore. I'm ready to pull my hair out =]

Any help would be appreciated!

jt1134
11-16-2009, 04:13 PM
you could start by posting at least ONE piece of pertitent information

"I have tried now with multiple different walkthroughs..." doesn't give us any idea as to what you've tried so far

did you make sure to replace the oil filter?

dthomas1234
11-16-2009, 04:29 PM
Sorry, I figured most were similar.

My unit is a Standalone tcd24008a
It has software version 9 on it.
I have successfully upgraded to a 200gb hard drive.
I have a linksys usb100m ethernet adapter that works fine before hack attempts.

Here are the 3 walkthroughs that I tried.

http://www.weethet.nl/english/tivo_dtv2_os6hack.php
http://homepage.mac.com/steventamm/tivo.html
http://www.techstorm.net/tivo/hackseries2.html

I have looked at about 20 of them, but almost all were similar to these 3.

Thanks

Jamie
11-16-2009, 08:35 PM
Almost all the "walkthroughs" are out of date and oriented towards dtivo users.

If I remember right, the 8.x and 9.x usb drivers are not compatible with the 7.x kernel you are likely using if you used killhdinitrd to break the chain of trust. So you can either: PROM-mod so you can directly boot an initrd killed 9.x kernel, Monte to a 9.x kernel that is compatible with your usb drivers, Use the backport (http://www.dealdatabase.com/forum/showthread.php?t=44114) usb drivers built for a pre 8.x kernel, or Try to dig up (http://www.dealdatabase.com/forum/showthread.php?p=283752#post283752) 7.x usb drivers and use them.History on the driver compatibility problem is in this (http://www.dealdatabase.com/forum/showthread.php?t=51874) thread.

Unrelated aside: The usb100m is limited to usb 1.1 speeds (max theoretical 12mbps; in practice, maybe half that), so it might make sense to upgrade to a usb2.0 adapter. You'd still have to face the driver compatibility issue, so that by itself is not the answer to your woes.